dev-libs/libgit2: Sec cleanup
authorMichał Górny <mgorny@gentoo.org>
Sun, 7 Oct 2018 08:13:15 +0000 (10:13 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 7 Oct 2018 08:16:43 +0000 (10:16 +0200)
Bug: https://bugs.gentoo.org/667860
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-libs/libgit2/Manifest
dev-libs/libgit2/libgit2-0.26.6.ebuild [deleted file]
dev-libs/libgit2/libgit2-0.27.4.ebuild [deleted file]

index 8c606febbe34d716fe76e841e36a6149d0cb8bee..b8320c5305fa8033f481ad94fa5de822d43ac04e 100644 (file)
@@ -1,4 +1,2 @@
-DIST libgit2-0.26.6.tar.gz 4734435 BLAKE2B 0831d0a78ba74b6cd989821f0abb6774f8879f18906025ce02d7c0f7f8f3e7f03b30121f79e370b85201e110a6fc4aca2ae2e608b12f01cd527ab42bf597099d SHA512 6a5a167bfe8696294cf188feec2aad898af52f4c05a3a40a55f48ea3168d200a60fc42b3819a22b1bf472be696f5dafef473d457c08bab164cbf654c4de6bda7
 DIST libgit2-0.26.7.tar.gz 4737641 BLAKE2B dd87ab3048dec361619ff0e42d19161e4b20a07d334ad42aa077b77202bf5e84b85e33a6d6668afef36a7ff23f85a68f28049e08dd7502b241e40a730a78bb44 SHA512 5ad0c514b6c1c58031029f4ada278a164cc112f25c36745973df27711f12888000c054816b65889576124e93b71ec9a1c4f4cc0b538f177d93a57bc145fea1e1
-DIST libgit2-0.27.4.tar.gz 4772254 BLAKE2B 9c0e7b436d8cb07a8f1407d22bcd4c7b161f3ceef9dc4e67f9daec784a1cfb9f8f2e493a78f5ef6b4893e54c1f1b567ae53ead52a992ee10eabe3229195417a1 SHA512 d27db86eb1b9f0d4057f8538ba1985ee76c3ca106e57d417fa9bff79d575f91a07ad28693112b58dc1d61d68116a82e6a145f12276158f2806b6c4964d741f61
 DIST libgit2-0.27.5.tar.gz 4775158 BLAKE2B 118af462a4969bc802451b887386e87da0f855641a774ce7460d6fe7ad9c62ce71a4b35a7461a95c7c4a96c59143c9c1acc78c5a1b21143a651491713f4fa15b SHA512 318b981456d55f60f8aa1897f1f70274329e48f09769b661eb4bbe76399071eca0fbc7deacb3191db16bc89dba8cc69a64adaf8cbc65e34a65b6e72ca122e21f
diff --git a/dev-libs/libgit2/libgit2-0.26.6.ebuild b/dev-libs/libgit2/libgit2-0.26.6.ebuild
deleted file mode 100644 (file)
index fe13563..0000000
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
-inherit cmake-utils python-any-r1
-
-if [[ ${PV} == "9999" ]] ; then
-       EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
-       inherit git-r3
-else
-       SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="amd64 ~arm ~arm64 ~ppc x86 ~ppc-macos"
-fi
-
-DESCRIPTION="A linkable library for Git"
-HOMEPAGE="https://libgit2.github.com/"
-
-LICENSE="GPL-2-with-linking-exception"
-SLOT="0/26"
-IUSE="+curl examples gssapi libressl +ssh test +threads trace"
-
-RDEPEND="
-       !libressl? ( dev-libs/openssl:0= )
-       libressl? ( dev-libs/libressl:0= )
-       sys-libs/zlib
-       net-libs/http-parser:=
-       curl? (
-               !libressl? ( net-misc/curl:=[curl_ssl_openssl(-)] )
-               libressl? ( net-misc/curl:=[curl_ssl_libressl(-)] )
-       )
-       gssapi? ( virtual/krb5 )
-       ssh? ( net-libs/libssh2 )
-"
-DEPEND="${RDEPEND}
-       ${PYTHON_DEPS}
-       virtual/pkgconfig
-"
-
-DOCS=( AUTHORS CONTRIBUTING.md CONVENTIONS.md README.md )
-
-src_prepare() {
-       # skip online tests
-       sed -i '/libgit2_clar/s/-ionline/-xonline/' CMakeLists.txt || die
-
-       cmake-utils_src_prepare
-}
-
-src_configure() {
-       local mycmakeargs=(
-               -DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
-               -DBUILD_CLAR=$(usex test)
-               -DENABLE_TRACE=$(usex trace)
-               -DUSE_GSSAPI=$(usex gssapi)
-               -DUSE_SSH=$(usex ssh)
-               -DTHREADSAFE=$(usex threads)
-               -DCURL=$(usex curl)
-       )
-       cmake-utils_src_configure
-}
-
-src_test() {
-       if [[ ${EUID} -eq 0 ]] ; then
-               # repo::iterator::fs_preserves_error fails if run as root
-               # since root can still access dirs with 0000 perms
-               ewarn "Skipping tests: non-root privileges are required for all tests to pass"
-       else
-               local TEST_VERBOSE=1
-               cmake-utils_src_test
-       fi
-}
-
-src_install() {
-       cmake-utils_src_install
-
-       if use examples ; then
-               find examples -name '.gitignore' -delete || die
-               dodoc -r examples
-               docompress -x /usr/share/doc/${PF}/examples
-       fi
-}
diff --git a/dev-libs/libgit2/libgit2-0.27.4.ebuild b/dev-libs/libgit2/libgit2-0.27.4.ebuild
deleted file mode 100644 (file)
index d100653..0000000
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
-inherit cmake-utils python-any-r1
-
-if [[ ${PV} == "9999" ]] ; then
-       EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
-       inherit git-r3
-else
-       SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~ppc-macos"
-fi
-
-DESCRIPTION="A linkable library for Git"
-HOMEPAGE="https://libgit2.github.com/"
-
-LICENSE="GPL-2-with-linking-exception"
-SLOT="0/27"
-IUSE="+curl examples gssapi libressl +ssh test +threads trace"
-
-RDEPEND="
-       !libressl? ( dev-libs/openssl:0= )
-       libressl? ( dev-libs/libressl:0= )
-       sys-libs/zlib
-       net-libs/http-parser:=
-       curl? (
-               !libressl? ( net-misc/curl:=[curl_ssl_openssl(-)] )
-               libressl? ( net-misc/curl:=[curl_ssl_libressl(-)] )
-       )
-       gssapi? ( virtual/krb5 )
-       ssh? ( net-libs/libssh2 )
-"
-DEPEND="${RDEPEND}
-       ${PYTHON_DEPS}
-       virtual/pkgconfig
-"
-
-DOCS=( AUTHORS CONTRIBUTING.md CONVENTIONS.md README.md )
-
-src_prepare() {
-       # skip online tests
-       sed -i '/libgit2_clar/s/-ionline/-xonline/' tests/CMakeLists.txt || die
-
-       cmake-utils_src_prepare
-}
-
-src_configure() {
-       local mycmakeargs=(
-               -DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
-               -DBUILD_CLAR=$(usex test)
-               -DENABLE_TRACE=$(usex trace)
-               -DUSE_GSSAPI=$(usex gssapi)
-               -DUSE_SSH=$(usex ssh)
-               -DTHREADSAFE=$(usex threads)
-               -DCURL=$(usex curl)
-       )
-       cmake-utils_src_configure
-}
-
-src_test() {
-       if [[ ${EUID} -eq 0 ]] ; then
-               # repo::iterator::fs_preserves_error fails if run as root
-               # since root can still access dirs with 0000 perms
-               ewarn "Skipping tests: non-root privileges are required for all tests to pass"
-       else
-               local TEST_VERBOSE=1
-               cmake-utils_src_test
-       fi
-}
-
-src_install() {
-       cmake-utils_src_install
-
-       if use examples ; then
-               find examples -name '.gitignore' -delete || die
-               dodoc -r examples
-               docompress -x /usr/share/doc/${PF}/examples
-       fi
-}