sci-libs/linux-gpib-modules: Remove old
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Sat, 9 May 2020 11:01:47 +0000 (14:01 +0300)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Sat, 9 May 2020 11:02:38 +0000 (14:02 +0300)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
sci-libs/linux-gpib-modules/Manifest
sci-libs/linux-gpib-modules/files/linux-gpib-modules-4.2.0_rc1-reallydie.patch [deleted file]
sci-libs/linux-gpib-modules/linux-gpib-modules-4.2.0.ebuild [deleted file]
sci-libs/linux-gpib-modules/metadata.xml

index f0c93807e781358da8aa9dbe105fcd2332fe73a1..0d85cdfe9eec10f1c8f8766d587a1f4f9067b7ce 100644 (file)
@@ -1,3 +1,2 @@
-DIST linux-gpib-4.2.0.tar.gz 1431440 BLAKE2B 7b6adf562963e0785f960c072f3f3d67cb91df9090205d8fecb0dc3170d3a1ac3719732919bae112e06b47387499ffe49a0144e72caa27ba39c85c8b98e56786 SHA512 1505c2c04f16bf7e92b9dd474f09edd242520a96f9e4d8eea88ebd44d0a82d653055155c1bfcde69da5355d609d400e3cb682da8aae83f59f1e565307a3fc4a7
 DIST linux-gpib-4.3.0.tar.gz 1375852 BLAKE2B e2daa444ddf4c0c34084f264247051d4ce1c8103d8ae5d91b02d4742131c1f92ded02775eb0f8b0ea29820e2ae7b61c3132c74084a876e86fbb4efaf11688773 SHA512 8db4eb6d606c68ffacc67988479684fec815fc552756a6c93466ef0dfc93368771bb551944e3afc31db83e72e464ec1fb289fdcf80b4a6be1617e734fe3b9d65
 DIST linux-gpib-4.3.2.tar.gz 1377406 BLAKE2B 57ec8b3788606ffb42d204ad0e2476c432bc82f929b1854c6a1d48c73f48a149716d05b13906b4597a4bf03e4c10a0ffe2c66e6de8cf9a5891b86c3d459713fc SHA512 bf9963d885e0c974f41eed96359501bd41c7d4f051026f64d835e52f1031f39e6bba6ce976a27e660a8b36087e56b81205206066c68b42db9a1d578d351a8f8b
diff --git a/sci-libs/linux-gpib-modules/files/linux-gpib-modules-4.2.0_rc1-reallydie.patch b/sci-libs/linux-gpib-modules/files/linux-gpib-modules-4.2.0_rc1-reallydie.patch
deleted file mode 100644 (file)
index cba29ee..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -ruN linux-gpib-kernel-4.2.0_rc1.orig/drivers/Makefile.am linux-gpib-kernel-4.2.0_rc1/drivers/Makefile.am
---- linux-gpib-kernel-4.2.0_rc1.orig/drivers/Makefile.am       2018-10-02 11:32:11.000000000 +0200
-+++ linux-gpib-kernel-4.2.0_rc1/drivers/Makefile.am    2018-10-09 12:03:21.272433209 +0200
-@@ -14,10 +14,8 @@
- -include $(top_srcdir)/util/linux_flags/flags
--#ignore errors from kernel's make modules in all-local, to avoid failure of make install
--#on nfs filesystem with root_squash
- all-local:
--      -$(MAKE) -C $(LINUX_SRCDIR) V=1 modules\
-+      $(MAKE) -C $(LINUX_SRCDIR) V=1 modules\
-               CC="$(LINUX_CC) -I@abs_top_srcdir@ -I@abs_top_srcdir@/compat/include" \
-               CONFIG_GPIB_ISA="$(ENABLE_ISA)" \
-               SUBDIRS="$(GPIB_ABS_MODULE_SUBDIR)"
diff --git a/sci-libs/linux-gpib-modules/linux-gpib-modules-4.2.0.ebuild b/sci-libs/linux-gpib-modules/linux-gpib-modules-4.2.0.ebuild
deleted file mode 100644 (file)
index 6a02d36..0000000
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit linux-info linux-mod autotools toolchain-funcs
-
-DESCRIPTION="Kernel modules for GPIB (IEEE 488.2) hardware"
-HOMEPAGE="https://linux-gpib.sourceforge.io/"
-SRC_URI="mirror://sourceforge/linux-gpib/linux-gpib-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~x86"
-IUSE="isa pcmcia debug"
-
-COMMONDEPEND=""
-RDEPEND="${COMMONDEPEND}
-       !<sci-libs/linux-gpib-4.2.0_rc1
-"
-DEPEND="${COMMONDEPEND}
-       virtual/pkgconfig"
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-4.2.0_rc1-reallydie.patch
-)
-
-S=${WORKDIR}/linux-gpib-kernel-${PV}
-
-pkg_setup() {
-       linux-mod_pkg_setup
-
-       if kernel_is -lt 2 6 8; then
-               die "Kernel versions older than 2.6.8 are not supported."
-       fi
-
-       # https://sourceforge.net/p/linux-gpib/bugs/43/
-       if use pcmcia && kernel_is -ge 2 6 38; then
-               die "pcmcia support is broken on kernels newer 2.6.38"
-       fi
-}
-
-src_unpack() {
-       default
-       unpack "${WORKDIR}/linux-gpib-${PV}/linux-gpib-kernel-${PV}.tar.gz"
-}
-
-src_prepare() {
-       default
-       eautoreconf
-}
-
-src_configure() {
-       set_arch_to_kernel
-       econf \
-               $(use_enable isa) \
-               $(use_enable pcmcia) \
-               $(use_enable debug driver-debug) \
-               --with-linux-srcdir=${KV_DIR}
-}
-
-src_compile() {
-       set_arch_to_kernel
-       emake \
-               DESTDIR="${D}" \
-               INSTALL_MOD_PATH="${D}" \
-               docdir=/usr/share/doc/${PF}/html
-}
-
-src_install() {
-       set_arch_to_kernel
-       emake \
-               DESTDIR="${D}" \
-               INSTALL_MOD_PATH="${D}" \
-               DEPMOD="/bin/true" \
-               docdir=/usr/share/doc/${PF}/html install
-
-       dodoc ChangeLog AUTHORS README* NEWS
-}
-
-pkg_preinst() {
-       linux-mod_pkg_preinst
-       enewgroup gpib
-}
-
-pkg_postinst() {
-       linux-mod_pkg_postinst
-}
index b53300ac1ed54a06fe74c5a55e8ed9d973870cb7..0781b9a96b943ceed7cb4717ad7e622c3ef3661f 100644 (file)
@@ -9,9 +9,6 @@
     <email>sci-electronics@gentoo.org</email>
     <name>Gentoo Electronics Project</name>
   </maintainer>
-  <use>
-    <flag name="isa">Build ISA kernel modules; from 3.12 on the setting is ignored and the decision based on the kernel configuration</flag>
-  </use>
   <upstream>
     <remote-id type="sourceforge">linux-gpib</remote-id>
   </upstream>