dev-python/pyenchant: Bump to 3.0.1
authorMichał Górny <mgorny@gentoo.org>
Sat, 11 Apr 2020 05:24:04 +0000 (07:24 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 11 Apr 2020 07:49:10 +0000 (09:49 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pyenchant/Manifest
dev-python/pyenchant/pyenchant-3.0.1.ebuild [new file with mode: 0644]

index 9c4095a2b2bb99e94f061ed7109f2db8382f39a8..743aced87bddc7428d1a35e252b29daba6e5b3d8 100644 (file)
@@ -1 +1,2 @@
 DIST pyenchant-2.0.0.tar.gz 64022 BLAKE2B ee1200ded8e2a8f9145fece64cee1c8ea3129d540e10708d51acf6491c200a0f39927b47fce51d2e2f932e465d7acd5bb4afd31712183530f6da5e8ea899c0c7 SHA512 c985714bc8ad69b6580fa1dd546243da5f3f92e8681d846ed265b086c486ae7ed33754fba303b450be4c0cb20e975a9a10efbeb700ea5213a11ed00612a93af0
+DIST pyenchant-3.0.1.gh.tar.gz 75730 BLAKE2B 499638a238fa00510c9fcd3bc3d91c6486af8476b857781e70c142bbabac3933611d96f745bd44cbf707a4051ea0b83534bfe1da78b9a5631dbd52c157f6b4c2 SHA512 61ab856071bb2c49b31f4f10562c0f6c2d1812537de927905427d61b9b183f8e25eb1ae01ca5655812512d9634be0e5fa7df8b393f9080e2ddd6700ccd049287
diff --git a/dev-python/pyenchant/pyenchant-3.0.1.ebuild b/dev-python/pyenchant/pyenchant-3.0.1.ebuild
new file mode 100644 (file)
index 0000000..413e9b9
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the Enchant spellchecking system"
+HOMEPAGE="https://github.com/pyenchant/pyenchant
+       https://pypi.org/project/pyenchant/"
+SRC_URI="
+       https://github.com/pyenchant/pyenchant/archive/v${PV}.tar.gz
+               -> ${P}.gh.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="app-text/enchant:0"
+BDEPEND="
+       test? (
+               app-dicts/myspell-en
+       )"
+
+distutils_enable_tests pytest