sys-apps/i2c-tools: Drop old
authorMikle Kolyada <zlogene@gentoo.org>
Wed, 11 Mar 2020 11:36:18 +0000 (14:36 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Wed, 11 Mar 2020 11:36:36 +0000 (14:36 +0300)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
sys-apps/i2c-tools/Manifest
sys-apps/i2c-tools/i2c-tools-4.0.ebuild [deleted file]

index dd40b32bbdd1ab2c614ea4d474f3c0b818474706..94fe0318fd076aef0b7b855c82e9fce8dba12bde 100644 (file)
@@ -1,2 +1 @@
-DIST i2c-tools-4.0.tar.xz 79972 BLAKE2B 982e4139ed0e2111f9e082d0690fcc0f86f97a433e292e9464b41991f14a1f90147a3612172bad6880f0df6896612e1dea0ae7bf6f459758b2cff45fb35a5dc7 SHA512 ddf86c357c101388193581bc40285089e6ab5e8d870f8aa5d594acc7ecb8596fbd30501e147b88bdea0200b1be88bc0a374356c188d1bcb067bf8e254e3dc51e
 DIST i2c-tools-4.1.tar.xz 83576 BLAKE2B 0a9ed3bb335b61f6c17a6b6c705502ff008b4fb8bab6a5fde63163a32528b5214d92affc4b8d6cca29676dc7ba82dfa84be5f14943b7e81c8612a7d9419ac628 SHA512 83262bcfd94c2adf74517cc50095dd78221fa4d16a62397245d4a538de7463272abf4f6727024be8ab1ca8ecbfe647af85ba2a553e5b5e68a53e50dfcad20248
diff --git a/sys-apps/i2c-tools/i2c-tools-4.0.ebuild b/sys-apps/i2c-tools/i2c-tools-4.0.ebuild
deleted file mode 100644 (file)
index f013280..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-DISTUTILS_OPTIONAL="1"
-
-inherit distutils-r1 flag-o-matic toolchain-funcs
-
-DESCRIPTION="I2C tools for bus probing, chip dumping, EEPROM decoding, and more"
-HOMEPAGE="https://www.kernel.org/pub/software/utils/i2c-tools"
-SRC_URI="https://www.kernel.org/pub/software/utils/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ~mips ~ppc ~ppc64 ~sparc x86"
-IUSE="python"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
-       python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
-       default
-       use python && distutils-r1_src_prepare
-}
-
-src_configure() {
-       use python && distutils-r1_src_configure
-}
-
-src_compile() {
-       emake all-lib AR=$(tc-getAR) CC=$(tc-getCC) # parallel make
-       emake CC=$(tc-getCC)
-       emake -C eepromer CC=$(tc-getCC) CFLAGS="${CFLAGS}"
-       if use python ; then
-               cd py-smbus || die
-               append-cppflags -I../include
-               distutils-r1_src_compile
-       fi
-}
-
-src_install() {
-       emake install-lib install libdir="${D}"/usr/$(get_libdir) prefix="${D}"/usr
-       dosbin eepromer/eeprom{,er}
-       rm -rf "${D}"/usr/include || die # part of linux-headers
-       dodoc CHANGES README
-       local d
-       for d in eeprom eepromer ; do
-               docinto ${d}
-               dodoc ${d}/README*
-       done
-
-       if use python ; then
-               cd py-smbus || die
-               docinto py-smbus
-               dodoc README*
-               distutils-r1_src_install
-       fi
-}