dev-python/google-apputils: Simplify permissions fix
authorMike Gilbert <floppym@gentoo.org>
Wed, 30 Sep 2015 16:26:43 +0000 (12:26 -0400)
committerMike Gilbert <floppym@gentoo.org>
Wed, 30 Sep 2015 16:28:03 +0000 (12:28 -0400)
Package-Manager: portage-2.2.22_p3

dev-python/google-apputils/google-apputils-0.4.0-r1.ebuild
dev-python/google-apputils/google-apputils-0.4.2-r1.ebuild

index 4ed6025a284285a8e17aa3b699f488056271eb9a..7b78e53c8ddbf520f22466d7bdd9b60aad41db80 100644 (file)
@@ -27,8 +27,7 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
 
 src_unpack() {
        default
-       find ${P} -type d -exec chmod 0755 {} + || die
-       find ${P} -type f -exec chmod 0644 {} + || die
+       chmod -R a+rX,u+w,g-w,o-w ${P} || die
 }
 
 python_prepare_all() {
index 613b4dcc67353e920849b0a5f7b7561c15a65001..1e3890860051de06bf8ec978bbc92513664a1228 100644 (file)
@@ -26,8 +26,7 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
 
 src_unpack() {
        default
-       find ${P} -type d -exec chmod 0755 {} + || die
-       find ${P} -type f -exec chmod 0644 {} + || die
+       chmod -R a+rX,u+w,g-w,o-w ${P} || die
 }
 
 python_test() {