x11-misc/bumblebee: sync 9999, minor syntax changes
authorNP-Hardass <NP-Hardass@gentoo.org>
Thu, 16 Feb 2017 22:33:27 +0000 (17:33 -0500)
committerNP-Hardass <NP-Hardass@gentoo.org>
Thu, 16 Feb 2017 22:35:35 +0000 (17:35 -0500)
Package-Manager: portage-2.3.0

x11-misc/bumblebee/bumblebee-3.2.1_p20170123.ebuild
x11-misc/bumblebee/bumblebee-9999.ebuild

index ef99702e33443e406906be2b192032a7e3b693c6..c95fb49785a3027e3cc5fd67e54e3e8ff535ac3a 100644 (file)
@@ -4,11 +4,13 @@
 
 EAPI=6
 
-inherit autotools readme.gentoo-r1 multilib systemd user
+inherit autotools multilib readme.gentoo-r1 systemd user
 
 if [[ ${PV} == 9999 ]]; then
+       inherit git-r3
        EGIT_REPO_URI="git://github.com/Bumblebee-Project/Bumblebee.git"
        EGIT_BRANCH="develop"
+       KEYWORDS=""
 else
        COMMIT="c322bd849aabe6e48b4304b8d13cc4aadc36a30d"
        SRC_URI="https://github.com/Bumblebee-Project/Bumblebee/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
@@ -62,12 +64,9 @@ src_prepare() {
 }
 
 src_configure() {
-       DOC_CONTENTS="In order to use Bumblebee, add your user to 'bumblebee' group.
-               You may need to setup your /etc/bumblebee/bumblebee.conf"
-
        if use video_cards_nvidia ; then
                # Get paths to GL libs for all ABIs
-               local nvlib=""
+               local nvlib=""
                for i in  $(get_all_libdirs) ; do
                        nvlib="${nvlib}:/usr/${i}/opengl/nvidia/lib"
                done
@@ -80,22 +79,18 @@ src_configure() {
        fi
 
        econf \
-               --docdir=/usr/share/doc/"${PF}" \
                ${ECONF_PARAMS}
 }
 
 src_install() {
+       default
+
        newconfd "${FILESDIR}"/${PN}.confd ${PN}
        newinitd "${FILESDIR}"/${PN}.initd ${PN}
        newenvd "${FILESDIR}"/${PN}.envd 99${PN}
        systemd_dounit scripts/systemd/bumblebeed.service
 
+       local DOC_CONTENTS="In order to use Bumblebee, add your user to 'bumblebee' group.
+               You may need to setup your /etc/bumblebee/bumblebee.conf"
        readme.gentoo_create_doc
-
-       default
 }
-#
-#pkg_preinst() {
-#      use video_cards_nvidia || rm "${ED}"/etc/bumblebee/xorg.conf.nvidia
-#      use video_cards_nouveau || rm "${ED}"/etc/bumblebee/xorg.conf.nouveau
-#}
index 4b832aebac22e7ceb38a09c01e957c4c436f1cc0..c95fb49785a3027e3cc5fd67e54e3e8ff535ac3a 100644 (file)
@@ -7,10 +7,10 @@ EAPI=6
 inherit autotools multilib readme.gentoo-r1 systemd user
 
 if [[ ${PV} == 9999 ]]; then
+       inherit git-r3
        EGIT_REPO_URI="git://github.com/Bumblebee-Project/Bumblebee.git"
        EGIT_BRANCH="develop"
        KEYWORDS=""
-       inherit git-r3
 else
        COMMIT="c322bd849aabe6e48b4304b8d13cc4aadc36a30d"
        SRC_URI="https://github.com/Bumblebee-Project/Bumblebee/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
@@ -84,6 +84,7 @@ src_configure() {
 
 src_install() {
        default
+
        newconfd "${FILESDIR}"/${PN}.confd ${PN}
        newinitd "${FILESDIR}"/${PN}.initd ${PN}
        newenvd "${FILESDIR}"/${PN}.envd 99${PN}
@@ -93,8 +94,3 @@ src_install() {
                You may need to setup your /etc/bumblebee/bumblebee.conf"
        readme.gentoo_create_doc
 }
-#
-#pkg_preinst() {
-#      use video_cards_nvidia || rm "${ED}"/etc/bumblebee/xorg.conf.nvidia
-#      use video_cards_nouveau || rm "${ED}"/etc/bumblebee/xorg.conf.nouveau
-#}