games-rpg/manaplus: Version 1.7.3.18 stable for amd64 and x86
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 4 Apr 2017 08:35:16 +0000 (10:35 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 4 Apr 2017 08:35:56 +0000 (10:35 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

games-rpg/manaplus/Manifest
games-rpg/manaplus/manaplus-1.7.3.18.ebuild
games-rpg/manaplus/manaplus-1.7.4.1.ebuild [new file with mode: 0644]

index 02c81bae3c321c97550327af7a2767f9f1461d69..d33a24be6d812654fc5558b77f688feb11bf18f5 100644 (file)
@@ -1,2 +1,3 @@
 DIST manaplus-1.7.3.18.tar.xz 14793708 SHA256 053908c2f42b9db637536adbcb84b31c3cf203af4d954cda26d78afa798cb5a6 SHA512 eb42a958d1ae60e2519ce94da0cda9dc01c3b0d5220e9538740e290d894e32201d8ad36e724c17120ceb414cb076636a7ae0b6c7dc09a3436160ed4f60f7351b WHIRLPOOL b7104267d3f50c6f6a37562a18506e3289eadb0468d562eed41c3aaf30a770e517e245840eae8f3d3d261eeca881662b5fc784d5323dd0d0de068c6f86fd5e9f
 DIST manaplus-1.7.3.4.tar.xz 14794704 SHA256 20d8ccd4d91edc0f9de4db9d5c0ae99906be393f6d762b87c2d784279ffe7d55 SHA512 86c45d5e2964772bd87bcb06b55dc8481ec1b36c3f5523015f2eba4c0adc15ea7d8ea9db7b98779f76cdbdd869687b93cc2f1a0012db44f7fffcd3ee3ffdae06 WHIRLPOOL 9caf975ec64183ea3241c0be29ddcde57902c0cbc945b8fc267ff8bbf77586043eaadc8277f771bffba2901c4da1663b094cc3169dd9bf1a9009dd6f9b1da0b3
+DIST manaplus-1.7.4.1.tar.xz 14800880 SHA256 9422f6c1d7a79a69a8c89c70f3608f7d3afc5d77faae04fd1457f5f7c96bace1 SHA512 3338b193a5a91e3cf8bdee28e1344fcb1fbdeea1edf14fa2257560fb2200656dbe2bbef7dd4df7a7796344c4b01f3974df239a3ab9d005ef7797268c20bd6b9e WHIRLPOOL 800d659b17b2415ea632159263612349100d78098e5f7d05c98713ab6747333d9c713014746bf2c9188d39c7cdd495e511970e5ecad74be662b09cc387bf5c35
index 7896a6774affe8ac2065107d292378a32318a760..658372c7dac68ca5c96222dbc644f6e75cb1bb76 100644 (file)
@@ -10,7 +10,7 @@ if [[ ${PV} == 9999 ]] ; then
        EGIT_REPO_URI="https://github.com/ManaPlus/ManaPlus.git"
 else
        SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/${P}.tar.xz"
-       KEYWORDS="~amd64 ~x86"
+       KEYWORDS="amd64 x86"
 fi
 
 LICENSE="GPL-2+"
diff --git a/games-rpg/manaplus/manaplus-1.7.4.1.ebuild b/games-rpg/manaplus/manaplus-1.7.4.1.ebuild
new file mode 100644 (file)
index 0000000..7896a67
--- /dev/null
@@ -0,0 +1,98 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
+HOMEPAGE="http://manaplus.evolonline.org"
+if [[ ${PV} == 9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/ManaPlus/ManaPlus.git"
+else
+       SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="mumble nls opengl pugixml +sdl2 test"
+
+RDEPEND="
+       >=dev-games/physfs-1.0.0
+       media-fonts/dejavu
+       media-fonts/liberation-fonts
+       media-fonts/mplus-outline-fonts
+       media-fonts/wqy-microhei
+       media-libs/libpng:0=
+       net-misc/curl
+       sys-libs/zlib
+       x11-apps/xmessage
+       x11-libs/libX11
+       x11-misc/xdg-utils
+       mumble? ( media-sound/mumble )
+       nls? ( virtual/libintl )
+       opengl? ( virtual/opengl )
+       pugixml? ( dev-libs/pugixml )
+       !pugixml? ( dev-libs/libxml2 )
+       sdl2? (
+               media-libs/libsdl2[X,opengl?,video]
+               media-libs/sdl2-gfx
+               media-libs/sdl2-image[png]
+               media-libs/sdl2-mixer[vorbis]
+               media-libs/sdl2-net
+               media-libs/sdl2-ttf
+       )
+       !sdl2? (
+               media-libs/libsdl[X,opengl?,video]
+               media-libs/sdl-gfx
+               media-libs/sdl-image[png]
+               media-libs/sdl-mixer[vorbis]
+               media-libs/sdl-net
+               media-libs/sdl-ttf
+       )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       nls? ( sys-devel/gettext )"
+
+src_prepare() {
+       default
+       if [[ ${PV} == 9999 ]] ; then
+               eautoreconf
+       fi
+}
+
+src_configure() {
+       CONFIG_SHELL=/bin/bash \
+       econf \
+               --localedir=/usr/share/locale \
+               --without-internalsdlgfx \
+               $(use_with mumble) \
+               $(use_enable nls) \
+               $(use_with opengl) \
+               --enable-libxml=$(usex pugixml pugixml libxml) \
+               $(use_with sdl2) \
+               $(use_enable test unittests)
+}
+
+src_install() {
+       default
+
+       local destpath="/usr/share/${PN}"
+       dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${destpath}"/data/fonts/dejavusans-bold.ttf
+       dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${destpath}"/data/fonts/dejavusans.ttf
+       dosym /usr/share/fonts/dejavu/DejaVuSansMono-Bold.ttf "${destpath}"/data/fonts/dejavusansmono-bold.ttf
+       dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${destpath}"/data/fonts/dejavusansmono.ttf
+       dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed-Bold.ttf "${destpath}"/data/fonts/dejavuserifcondensed-bold.ttf
+       dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed.ttf "${destpath}"/data/fonts/dejavuserifcondensed.ttf
+       dosym /usr/share/fonts/liberation-fonts/LiberationMono-Bold.ttf "${destpath}"/data/fonts/liberationsansmono-bold.ttf
+       dosym /usr/share/fonts/liberation-fonts/LiberationMono-Regular.ttf "${destpath}"/data/fonts/liberationsansmono.ttf
+       dosym /usr/share/fonts/liberation-fonts/LiberationSans-Bold.ttf "${destpath}"/data/fonts/liberationsans-bold.ttf
+       dosym /usr/share/fonts/liberation-fonts/LiberationSans-Regular.ttf "${destpath}"/data/fonts/liberationsans.ttf
+       dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-bold.ttf "${destpath}"/data/fonts/mplus-1p-bold.ttf
+       dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-regular.ttf "${destpath}"/data/fonts/mplus-1p-regular.ttf
+       dosym /usr/share/fonts/wqy-microhei/wqy-microhei.ttc "${destpath}"/data/fonts/wqy-microhei.ttf
+}
+
+src_test() {
+       make check
+}