sys-devel/crossdev: bump up to 20200131
authorSergei Trofimovich <slyfox@gentoo.org>
Fri, 13 Mar 2020 07:39:05 +0000 (07:39 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Fri, 13 Mar 2020 07:39:31 +0000 (07:39 +0000)
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-devel/crossdev/Manifest
sys-devel/crossdev/crossdev-20200131.ebuild [new file with mode: 0644]

index 5f295ac037ed675829d305f355daf81e2c590484..c8ee390cf1c5aee173ee26b1f3d67f50db3a59be 100644 (file)
@@ -1,2 +1,3 @@
 DIST crossdev-20191222.tar.xz 27320 BLAKE2B 375e0ccb7bfd5c5c365b9c874a7dbf75207843b68dbe6d4cf9da07b36efb7b3bb1e6c84f85268fea6c71d6afc1e284f9bd1dcfeca5536d0947f8d3a3f5344ca9 SHA512 ad32f2231663f312b2b35bdea81c9ddac584d13f9affd496f36cbed072a97e6f80deb3436dcbea184621a4bd86bb25d52fb0434208226a3d743f0f664cd91fd0
 DIST crossdev-20200125.tar.xz 27380 BLAKE2B 4871b3ba1130c8d2e4df263aea155f95352417e65dabe64968cf9cc2628f9a1ae32a7e569cdea73a04d32d05396b0a83720bbd712a5f5b703606692e6b61516b SHA512 a4db1d09179b23f032af59c4857c3ab58d7944633b0c612a1f8aa0ecc38201f960cc1da761f34288568bb7f3434fe4da5094b4d4445be047da8838a096f6c606
+DIST crossdev-20200131.tar.xz 28200 BLAKE2B b1b8e283d150968339e259c48b3f066f5233af2578b04e060d5e69c002af6ffd65214c559353a8ebcf3238c2b60d0ddfa29131e26c707647717088df55f77282 SHA512 e1d18a7d69cdc0240d30e77b1634bd6b5806e1576227e4ffa394805aa217c050ced75436e9a004a35bc9bc47b96ea2f3d8e19ef530a106736f7cc0d995bee4a5
diff --git a/sys-devel/crossdev/crossdev-20200131.ebuild b/sys-devel/crossdev/crossdev-20200131.ebuild
new file mode 100644 (file)
index 0000000..e37579f
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "99999999" ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
+else
+       SRC_URI="mirror://gentoo/${P}.tar.xz
+               https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Crossdev"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       >=sys-apps/portage-2.1
+       >=app-portage/portage-utils-0.55
+       app-shells/bash
+       sys-apps/gentoo-functions
+"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+       default
+
+       if [[ "${PV}" == "99999999" ]] ; then
+               sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+       fi
+}