dev-libs/intel-neo: bump to 20.10.16087
authorMarek Szuba <marecki@gentoo.org>
Fri, 13 Mar 2020 15:39:54 +0000 (16:39 +0100)
committerMarek Szuba <marecki@gentoo.org>
Fri, 13 Mar 2020 16:04:10 +0000 (17:04 +0100)
Signed-off-by: Marek Szuba <marecki@gentoo.org>
dev-libs/intel-neo/Manifest
dev-libs/intel-neo/intel-neo-20.10.16087.ebuild [new file with mode: 0644]

index 2e3340a7f2d32aef776add32b4409bbdabd84ed8..f2624fb59db3ed6fa1aba142a6d060287f38c291 100644 (file)
@@ -1,2 +1,3 @@
 DIST intel-neo-19.48.14977.tar.gz 2633172 BLAKE2B 296c85c89833e49f66c428b62fda9753de260bfc819ee24846bc100021f103d2dcc432a9a8a60d310737470c7a4afece4fef557f72da40470ea950f8198bda0e SHA512 24a5f5306b90c763e803c34d3f20227ae0f22e6ff4192a0550e9e3050173b50f2b2e391250f1733676eca45002a061e2c753e7546db7dd21af7c1ed0857f329f
 DIST intel-neo-20.03.15346.tar.gz 2671869 BLAKE2B cf1e242563a377d533b1e5adc89257e3fdd879a0f275f069e9c1c3c8436e269a1ec57e951394d2a487148bfc5393fed0ce1f3feb6954c7ece9de59cccffd628c SHA512 4d2cc8fdcba714832306e6353e8688e12c44eb0f848aad981951ee092274ba8ae032db462b49e874b7ac72e1b8b2b9ba71a84b6715ca241c06a1c70e753e5ed3
+DIST intel-neo-20.10.16087.tar.gz 2942516 BLAKE2B ed77e5dfe950794e9e34cc6a0d8c053292b5673b9fa244ef7b861da93bb6aa58161ad890719013c838b0bbd80f3c22aaafc60dcb72a1e1e565cab51e5467c810 SHA512 8a728a3cffb5960dba8e8ecc160a6f0dd9c2cbadead3db3af2df71af492fdb346628a20c55112e64debb32eb25cf549e42dc78a606ef4bb8f746913781dbb446
diff --git a/dev-libs/intel-neo/intel-neo-20.10.16087.ebuild b/dev-libs/intel-neo/intel-neo-20.10.16087.ebuild
new file mode 100644 (file)
index 0000000..0e9d2b7
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+MY_PN="compute-runtime"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Intel Graphics Compute Runtime for OpenCL, for Gen8 (Broadwell) and beyond"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="vaapi"
+
+BDEPEND="virtual/pkgconfig"
+COMMON="dev-libs/ocl-icd
+       >=dev-util/intel-graphics-compiler-1.0.3445
+       >=media-libs/gmmlib-19.4.1
+       vaapi? (
+               x11-libs/libdrm[video_cards_intel]
+               x11-libs/libva
+       )"
+DEPEND="${COMMON}
+       media-libs/mesa"        # for Khronos OpenGL headers
+RDEPEND="${COMMON}"
+
+DOCS=(
+       README.md
+       FAQ.md
+)
+
+S="${WORKDIR}"/${MY_P}
+
+src_configure() {
+       local mycmakeargs=(
+               -DKHRONOS_GL_HEADERS_DIR="${EPREFIX}/usr/include"
+               -DDISABLE_LIBVA=$(usex vaapi "OFF" "ON")
+               # If enabled, tests are automatically run during the compile phase
+               # - and we cannot run them because they require permissions to access
+               # the hardware.
+               -DSKIP_UNIT_TESTS=ON
+       )
+       cmake_src_configure
+}
+
+pkg_postinst() {
+       "${ROOT}"/usr/bin/eselect opencl set --use-old ocl-icd
+}