net-im/skypeforlinux: Bump version to 8.54.0.91
authorJan Vesely <jano.vesely@gmail.com>
Thu, 14 Nov 2019 19:55:28 +0000 (14:55 -0500)
committerJoonas Niilola <juippis@gentoo.org>
Mon, 18 Nov 2019 06:14:16 +0000 (08:14 +0200)
Signed-off-by: Jan Vesely <jano.vesely@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/13692
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-im/skypeforlinux/Manifest
net-im/skypeforlinux/skypeforlinux-8.54.0.91.ebuild [new file with mode: 0644]

index e51eb0d583115639b94f4ae6b70de3c48e0c1aea..73d26a2a9b3893b81b41a13d1d2957efbe54c249 100644 (file)
@@ -1,3 +1,4 @@
 DIST skypeforlinux_8.52.0.138-1.x86_64.rpm 106539045 BLAKE2B f07275b050ef63f87dfe54633ffa8446c5aa7a3db40e1eeea9c0902e9f7726fab59c7c1e55fd7af9b3f92bfb87a90b74851eeb334e415ed3b90f20013eda2b25 SHA512 dffb71138116c7c657a16cb7811e201d70b8d41242d3f1616f7e1ac71d6db60db487184b241b8290e4aa61fe755555b470db5731b269afd1d81c502e42bc31e7
 DIST skypeforlinux_8.53.0.85-1.x86_64.rpm 106728092 BLAKE2B 339630b4090b5b30144f6f023b256117c5ea8868af560a337c7f1c6a8c584a95d5f532300d26e3b417fe74b12806b59d6705cbf6a3a77e37803df03eb2cf92f4 SHA512 00de445d903e30f05d9ef7de7016907688dd667a17e542f082842837311b3050af5fe38fdf2d62b9494e308131b2cddac520ef1ba64461c15937a69a4a92abc0
 DIST skypeforlinux_8.54.0.85-1.x86_64.rpm 107064758 BLAKE2B 2a733286297d710c8e44c9f8367d32db517d81e42a4b5c17d94beaa00a725349327136f89f6022fed47c302cf90322322944c1ecacb8c770bf0c3eb4f22d9cdf SHA512 bb673d198e4c63b846acf6b4cdfc962d25a4128b081a46ccb786925f74aa5a3b0e11b9aecb39a52d913a53908d9b62aaf1905c1d49a8fcca0552fe752e3b71f9
+DIST skypeforlinux_8.54.0.91-1.x86_64.rpm 107062984 BLAKE2B b5886adc01fd0ff65fcd97403f2a8b50e28e5e99a0c2d359d0b17aafea4bc932d3b2b7da76ada22d64940cc2186899b6119caa406c654f665f7a0a4e78632a5e SHA512 f6df86a1e5dc5722d623bdaf5ce36df570421ebd524d76d7d9e3d0c85058304ab7248b454ce85b578bae798aa79dc4a067c5334182df1a828334f62640a89c59
diff --git a/net-im/skypeforlinux/skypeforlinux-8.54.0.91.ebuild b/net-im/skypeforlinux/skypeforlinux-8.54.0.91.ebuild
new file mode 100644 (file)
index 0000000..7e1b0f8
--- /dev/null
@@ -0,0 +1,107 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit chromium-2 desktop pax-utils rpm multilib-build xdg
+
+DESCRIPTION="Instant messaging client, with support for audio and video"
+HOMEPAGE="https://www.skype.com/"
+SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"
+
+LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="pax_kernel"
+
+S="${WORKDIR}"
+QA_PREBUILT="*"
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="
+       || (
+               sys-auth/elogind
+               sys-apps/systemd
+               net-im/skype-dbus-mock
+       )
+       app-crypt/libsecret[${MULTILIB_USEDEP}]
+       dev-libs/atk[${MULTILIB_USEDEP}]
+       dev-libs/expat[${MULTILIB_USEDEP}]
+       dev-libs/glib:2[${MULTILIB_USEDEP}]
+       dev-libs/nspr[${MULTILIB_USEDEP}]
+       dev-libs/nss[${MULTILIB_USEDEP}]
+       media-libs/alsa-lib[${MULTILIB_USEDEP}]
+       media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+       media-libs/freetype:2[${MULTILIB_USEDEP}]
+       media-libs/libv4l[${MULTILIB_USEDEP}]
+       net-print/cups[${MULTILIB_USEDEP}]
+       sys-apps/dbus[${MULTILIB_USEDEP}]
+       sys-devel/gcc[cxx]
+       virtual/ttf-fonts
+       x11-libs/cairo[${MULTILIB_USEDEP}]
+       x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+       x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+       x11-libs/libX11[${MULTILIB_USEDEP}]
+       x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
+       x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+       x11-libs/libXcursor[${MULTILIB_USEDEP}]
+       x11-libs/libXdamage[${MULTILIB_USEDEP}]
+       x11-libs/libXext[${MULTILIB_USEDEP}]
+       x11-libs/libXfixes[${MULTILIB_USEDEP}]
+       x11-libs/libXi[${MULTILIB_USEDEP}]
+       x11-libs/libXrandr[${MULTILIB_USEDEP}]
+       x11-libs/libXrender[${MULTILIB_USEDEP}]
+       x11-libs/libXtst[${MULTILIB_USEDEP}]
+       x11-libs/libxcb[${MULTILIB_USEDEP}]
+       x11-libs/libxkbfile[${MULTILIB_USEDEP}]
+       x11-libs/pango[${MULTILIB_USEDEP}]"
+
+pkg_setup() {
+       chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+       rpm_src_unpack ${A}
+}
+
+src_prepare() {
+       default
+       sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
+               -i usr/bin/skypeforlinux || die
+       sed -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+               -e "/^OnlyShowIn=/d" \
+               -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+       dodir /opt
+       cp -a usr/share/skypeforlinux "${D}"/opt || die
+
+       dobin usr/bin/skypeforlinux
+
+       dodoc usr/share/skypeforlinux/*.html
+       dodoc -r usr/share/doc/skypeforlinux/.
+       # symlink required for the "Help->3rd Party Notes" menu entry  (otherwise frozen skype -> xdg-open)
+       dosym ${PF} usr/share/doc/skypeforlinux
+
+       doicon usr/share/pixmaps/skypeforlinux.png
+
+       local res
+       for res in 16 32 256 512; do
+               newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+       done
+
+       domenu usr/share/applications/skypeforlinux.desktop
+
+       if use pax_kernel; then
+               pax-mark -m "${ED}"/opt/skypeforlinux/skypeforlinux
+               pax-mark -m "${ED}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+               ewarn "You have set USE=pax_kernel meaning that you intend to run"
+               ewarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+               ewarn "the ${PN} binary itself and this *may* lead to breakage! If"
+               ewarn "you suspect that ${PN} is being broken by this modification,"
+               ewarn "please open a bug."
+       fi
+}