gnome-extra/yelp: bump to 3.34.0
authorMart Raudsepp <leio@gentoo.org>
Tue, 17 Mar 2020 18:54:24 +0000 (20:54 +0200)
committerMart Raudsepp <leio@gentoo.org>
Tue, 17 Mar 2020 19:05:21 +0000 (21:05 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
gnome-extra/yelp/Manifest
gnome-extra/yelp/yelp-3.34.0.ebuild [new file with mode: 0644]

index ad16ae060d082b514fd731449b994351b9b8b05c..c602d09bfb123b7ef2dc7d0e98ace5f3b2541bf3 100644 (file)
@@ -1 +1,2 @@
 DIST yelp-3.32.2.tar.xz 1538964 BLAKE2B f4d7947f29b40bc033e2d3e010c39f8ff43de765bc4a2c446f02beab4888ded287681db2c140951f19aa9075aceff6f08658d0f434b5cd9d39e7e53e6cc00c31 SHA512 be0e2a7919ba8aef8eeb13e4d195e745afcd113350b32bad5ccf204f544107bebcadee364508402ad7906dd5484b9f21288ae13edcaab47a02b54e31f3379cfd
+DIST yelp-3.34.0.tar.xz 1538980 BLAKE2B 5b9af7a0f1b334555d6a4af2aff658a20e1b703f67663437fe4a967d5501382b23b2c8247908a232c79ec93fd6c7e1634816b3ce34eb11e609f4a6734ab06f4c SHA512 799a55df98bf176ee19e9b48ef321734b5df9d8c83bdb5c8c910b3def214039c8730a079d032b88dcc886c70418abb968c85c5c998b8ac340fc5ce27e6228eaf
diff --git a/gnome-extra/yelp/yelp-3.34.0.ebuild b/gnome-extra/yelp/yelp-3.34.0.ebuild
new file mode 100644 (file)
index 0000000..49c176d
--- /dev/null
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit autotools gnome2
+
+DESCRIPTION="Help browser for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Yelp"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND="
+       app-arch/bzip2:=
+       >=app-arch/xz-utils-4.9:=
+       dev-db/sqlite:3=
+       >=dev-libs/glib-2.38:2
+       >=dev-libs/libxml2-2.6.5:2
+       >=dev-libs/libxslt-1.1.4
+       >=gnome-extra/yelp-xsl-3.27.1
+       >=net-libs/webkit-gtk-2.19.2:4
+       >=x11-libs/gtk+-3.13.3:3
+       x11-themes/adwaita-icon-theme
+"
+DEPEND="${RDEPEND}
+       dev-libs/appstream-glib
+       >=dev-util/gtk-doc-am-1.13
+       dev-util/glib-utils
+       dev-util/itstool
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+"
+
+src_prepare() {
+       # Fix compatibility with Gentoo's sys-apps/man
+       # https://bugzilla.gnome.org/show_bug.cgi?id=648854
+       eapply "${FILESDIR}"/${PN}-3.20.0-man-compatibility.patch
+
+       eautoreconf
+       gnome2_src_prepare
+}
+
+src_configure() {
+       gnome2_src_configure \
+               --disable-static \
+               --enable-bz2 \
+               --enable-lzma \
+               APPSTREAM_UTIL=$(type -P true)
+}
+
+src_install() {
+       gnome2_src_install
+       exeinto /usr/libexec/
+       doexe "${S}"/libyelp/yelp-groff
+}