dev-python/qrcode: Set DISTUTILS_USE_SETUPTOOLS
authorMichał Górny <mgorny@gentoo.org>
Fri, 6 Mar 2020 03:24:08 +0000 (04:24 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 6 Mar 2020 03:24:08 +0000 (04:24 +0100)
Closes: https://bugs.gentoo.org/711592
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/qrcode/qrcode-6.1.ebuild

index 6478dfae767c3ff8f2c0e84ac686fa4f1f9ff934..302af0286b49698e79531ff986f24b6bfcf5860b 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=7
 
+DISTUTILS_USE_SETUPTOOLS=rdepend
 PYTHON_COMPAT=( python3_{6,7,8} )
 
 inherit distutils-r1
@@ -21,8 +22,6 @@ RDEPEND="
        dev-python/six[${PYTHON_USEDEP}]
        dev-python/lxml[${PYTHON_USEDEP}]
        dev-python/pillow[${PYTHON_USEDEP}]"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]"
 
 distutils_enable_tests unittest