dev-python/pytest-localserver: Version bump to 0.5.0
authorPatrick McLean <patrick.mclean@sony.com>
Wed, 20 Nov 2019 22:26:32 +0000 (14:26 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Thu, 21 Nov 2019 02:02:30 +0000 (18:02 -0800)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/pytest-localserver/Manifest
dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild [new file with mode: 0644]

index 77de89590f9b49f61da71988f40bac425e356b9a..4b6c80df33cfa40f9a4718ca7d49411aba0df24e 100644 (file)
@@ -1 +1,2 @@
 DIST pytest-localserver-0.3.7.tar.gz 19772 BLAKE2B 388bb7c2cfd4867bc028c23dea775ee463d947bc9bcd0a3e671b3c240c025ceed8eac75a2d05011564ff4c8c1e1153759033272cde0ffa9c3b2128156ad1b38f SHA512 48d7e6a27965dafa1d5e5af1efb6118cc1c1c28ac4a46ae2d61b6b804292a126f481295bf13976f66f505789238f3365ff16e6f1207c8bc7fb4b258759fd4d99
+DIST pytest-localserver-0.5.0.tar.gz 20409 BLAKE2B 62376065ee1aeb698ea5e3bd2d5ea3d6b511cc6793142aad458423513b0e3b358a0d0269a78a0f5aeda44fc53757ff85da786627840ee48cbed8b78ee34c2227 SHA512 aedf1e1c9563396457070df13df228ad0ebdd19173fa2ac5a598288d3e1a1ac8b8a0c0288cba0d8478e43d2e1de4848f2393bf640705916957f12ab31171c6cc
diff --git a/dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild b/dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild
new file mode 100644 (file)
index 0000000..3a496a8
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_{5,6,7}} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="Py.test plugin to test server connections locally"
+HOMEPAGE="https://pypi.org/project/pytest-localserver/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/werkzeug-0.10[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               ${RDEPEND}
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/requests[${PYTHON_USEDEP}]
+               dev-python/six[${PYTHON_USEDEP}]
+       )"
+
+distutils_enable_tests pytest