www-client/qutebrowser: Add version bump 1.8.3
authorGuillaume Seren <guillaumeseren@gmail.com>
Fri, 27 Dec 2019 19:55:35 +0000 (20:55 +0100)
committerSebastian Pipping <sping@gentoo.org>
Fri, 27 Dec 2019 21:32:23 +0000 (22:32 +0100)
Closes: https://bugs.gentoo.org/704040
Signed-off-by: Guillaume Seren <guillaumeseren@gmail.com>
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.79, Repoman-2.3.16

www-client/qutebrowser/Manifest
www-client/qutebrowser/qutebrowser-1.8.3.ebuild [new file with mode: 0644]

index b9cb17b7e30945b74d353a127c1b0fe182995795..5a094087d3133383ca63b9a05f6c46e36e2ad8f1 100644 (file)
@@ -1 +1,2 @@
 DIST qutebrowser-1.8.1.tar.gz 3605606 BLAKE2B 5f60de24738aa9cab88149193c6ce884c663edaed6e018ce56d582eac5489af2f889d8a8074949165e4302847dda61695039d95df4dc992516d3b4e42b2abe8e SHA512 5fff6a8590bb4fd26815984310e5ce57201eed9a4a1fb788594d70e64e00a666563851b376bbac78cb175d64ffbe34a032521db31ae389958fab796ee9c26c78
+DIST qutebrowser-1.8.3.tar.gz 3634523 BLAKE2B c36abcbd99767e3dbc7113d6432c5b7b2e4062e8b2892dbc15c4ffcde1d7b8f2d918674e3f5f0acf6b5e45eef794019f0cda1d9462da614ece8d1582952a0a95 SHA512 9a3dc3040d1236c81933263e031db4d44c86be206c54f0787a73b2dd7d32d6e742f9ac80626163515e917fbc9fa1588f76afcb21f4b3d31f47ba386d06c3c6e7
diff --git a/www-client/qutebrowser/qutebrowser-1.8.3.ebuild b/www-client/qutebrowser/qutebrowser-1.8.3.ebuild
new file mode 100644 (file)
index 0000000..73b3f30
--- /dev/null
@@ -0,0 +1,80 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
+
+inherit desktop distutils-r1 eutils xdg-utils
+
+DESCRIPTION="A keyboard-driven, vim-like browser based on PyQt5 and QtWebEngine"
+HOMEPAGE="https://www.qutebrowser.org/ https://github.com/qutebrowser/qutebrowser"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="scripts test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="
+       app-text/asciidoc
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND="
+       >=dev-python/attrs-19.1.0[${PYTHON_USEDEP}]
+       >=dev-python/colorama-0.4.1[${PYTHON_USEDEP}]
+       >=dev-python/cssutils-1.0.2[${PYTHON_USEDEP}]
+       >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+       >=dev-python/pygments-2.4.2[${PYTHON_USEDEP}]
+       >=dev-python/pypeg2-2.15.2[${PYTHON_USEDEP}]
+       || (  (
+                       >=dev-python/PyQt5-5.12[${PYTHON_USEDEP},declarative,multimedia,gui,network,opengl,printsupport,sql,widgets]
+                       dev-python/PyQtWebEngine[${PYTHON_USEDEP}] )
+               <dev-python/PyQt5-5.12[${PYTHON_USEDEP},declarative,multimedia,gui,network,opengl,printsupport,sql,webengine,widgets]
+       )
+       >=dev-python/pyyaml-5.1.2[${PYTHON_USEDEP},libyaml]
+"
+
+# Tests restricted as the deplist (misc/requirements/requirements-tests.txt)
+# isn't complete and X11 is required in order to start up qutebrowser.
+RESTRICT="test"
+
+python_compile_all() {
+       a2x -f manpage doc/${PN}.1.asciidoc || die "Failed generating man page"
+}
+
+python_test() {
+       py.test tests || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+       doman doc/${PN}.1
+       domenu misc/org.${PN}.${PN}.desktop
+       doicon -s scalable icons/${PN}.svg
+
+       if use scripts; then
+               # Install only those userscripts that have an explicit license header
+               exeinto /usr/share/qutebrowser/userscripts/
+               doexe misc/userscripts/dmenu_qutebrowser
+               doexe misc/userscripts/openfeeds
+               doexe misc/userscripts/qute-keepass
+               doexe misc/userscripts/qute-pass
+               doexe misc/userscripts/rss
+               doexe misc/userscripts/tor_identity
+       fi
+
+       distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+       optfeature "PDF display support" www-plugins/pdfjs
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+       xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+       xdg_mimeinfo_database_update
+}