dev-python/pylibmc: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 17:38:48 +0000 (18:38 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 17:44:09 +0000 (18:44 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pylibmc/Manifest
dev-python/pylibmc/pylibmc-1.5.1-r1.ebuild [deleted file]

index f98ddd40cd53242278463595ea29047c77b8318f..68a4f2e095a67b29deab390b350f1c391952255a 100644 (file)
@@ -1,2 +1 @@
-DIST pylibmc-1.5.1.tar.gz 69525 BLAKE2B 5039ad7d99a5ca57bd6cf7f00c77cc8bba122fe5852de164df34a71b4f5d1e4fcb428e749a66d384691b74f30b99e000f5cb9cd6479af2fc324d885b0fa59aa7 SHA512 efc40fae9721a6be589f87b66109132d4656725f718e1d63d7d25b9b27790b7c00fc3c7e4e47235895b7127cebc64229ddb284d23d0d903d3a510da7e1ce4549
 DIST pylibmc-1.6.1.tar.gz 72061 BLAKE2B ebaa6f9dfc341d862a8b46bbbf0db1420ff400cb40390f7bee6bf198ff941ad7967b578040ffe1209721ea84a163a39649108a2a23f3dadc2d579db740b2ccf3 SHA512 a3874435389486b29bab5f1d29e5c179d67655d90995bb27fcb7cd46ce7eb3b60117b94f901602f8a65dc0e587d5f8edfcf15e259effd439411adb58ddb7065e
diff --git a/dev-python/pylibmc/pylibmc-1.5.1-r1.ebuild b/dev-python/pylibmc/pylibmc-1.5.1-r1.ebuild
deleted file mode 100644 (file)
index a8c201b..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Libmemcached wrapper written as a Python extension"
-HOMEPAGE="http://sendapatch.se/projects/pylibmc/ https://pypi.org/project/pylibmc/"
-# One image is missing from the doc at PyPI
-# https://github.com/lericson/pylibmc/pull/221
-SRC_URI="https://github.com/lericson/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-libs/libmemcached-0.32"
-# Older sphinx versions fail to compile the doc
-# https://github.com/sphinx-doc/sphinx/issues/3266
-DEPEND="${RDEPEND}
-       doc? ( >=dev-python/sphinx-1.5.1-r1[${PYTHON_USEDEP}] )
-       test? (
-               net-misc/memcached
-               dev-python/nose[${PYTHON_USEDEP}]
-       )"
-
-python_prepare_all() {
-       sed -e "/with-info=1/d" -i setup.cfg || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               # This variable is added to sys.path
-               # but it does not seem to be useful
-               PYLIBMC_DIR="." emake -C docs
-               HTML_DOCS=( docs/_build/html/. )
-       fi
-}
-
-python_test() {
-       memcached -d -p 11219 -u nobody -l localhost -P "${T}/m.pid" || die
-       MEMCACHED_PORT=11219 nosetests
-       local ret=${?}
-       kill "$(<"${T}/m.pid")" || die
-       [[ ${ret} == 0 ]] || die "Tests fail with ${EPYTHON}!"
-}