net-vpn/wireguard-modules: include sch_generic.h header for skb_reset_tc
authorJason A. Donenfeld <zx2c4@gentoo.org>
Thu, 16 Apr 2020 09:29:58 +0000 (03:29 -0600)
committerJason A. Donenfeld <zx2c4@gentoo.org>
Thu, 16 Apr 2020 09:30:15 +0000 (03:30 -0600)
Fixes: https://bugs.gentoo.org/717582
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
net-vpn/wireguard-modules/files/wireguard-modules-1.0.20200413-sch_generic-header.patch [new file with mode: 0644]
net-vpn/wireguard-modules/wireguard-modules-1.0.20200413.ebuild

diff --git a/net-vpn/wireguard-modules/files/wireguard-modules-1.0.20200413-sch_generic-header.patch b/net-vpn/wireguard-modules/files/wireguard-modules-1.0.20200413-sch_generic-header.patch
new file mode 100644 (file)
index 0000000..8e263e9
--- /dev/null
@@ -0,0 +1,26 @@
+From bd388363a66d67f0e04f9c45b20a9f33dfcf79f6 Mon Sep 17 00:00:00 2001
+From: "Jason A. Donenfeld" <Jason@zx2c4.com>
+Date: Thu, 16 Apr 2020 00:27:33 -0600
+Subject: compat: include sch_generic.h header for skb_reset_tc
+
+Reported-by: King DuckZ <dev00@gmx.it>
+Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
+---
+ src/compat/compat.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/compat/compat.h b/src/compat/compat.h
+index 75bd3b7..bb996b8 100644
+--- a/src/compat/compat.h
++++ b/src/compat/compat.h
+@@ -1029,6 +1029,7 @@ out:
+ #if LINUX_VERSION_CODE < KERNEL_VERSION(5, 4, 29) || (LINUX_VERSION_CODE >= KERNEL_VERSION(5, 5, 0) && LINUX_VERSION_CODE < KERNEL_VERSION(5, 5, 14))
+ #include <linux/skbuff.h>
++#include <net/sch_generic.h>
+ static inline void skb_reset_redirect(struct sk_buff *skb)
+ {
+ #ifdef CONFIG_NET_SCHED
+-- 
+cgit v1.2.3-4-ga26e
+
index 16df945c1ab1c7452406e43350a620396d810cc0..8a425d4191e698477e156074b5a30f30b2d31004 100644 (file)
@@ -30,6 +30,8 @@ MODULE_NAMES="wireguard(kernel/drivers/net:src)"
 BUILD_TARGETS="module"
 CONFIG_CHECK="NET INET NET_UDP_TUNNEL CRYPTO_ALGAPI"
 
+PATCHES=( "${FILESDIR}/${P}-sch_generic-header.patch" )
+
 pkg_setup() {
        if use module; then
                linux-mod_pkg_setup