sys-apps/yarn: Bump to version 1.22.4
authorZac Medico <zmedico@gentoo.org>
Wed, 11 Mar 2020 05:00:56 +0000 (22:00 -0700)
committerZac Medico <zmedico@gentoo.org>
Wed, 11 Mar 2020 05:03:42 +0000 (22:03 -0700)
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Zac Medico <zmedico@gentoo.org>
sys-apps/yarn/Manifest
sys-apps/yarn/yarn-1.22.4.ebuild [new file with mode: 0644]

index 5b73665fc750d2fcd513282f493e1bbed23fb4ca..53cae8aaee3ff1f3e4de806434989743690b6ec2 100644 (file)
@@ -1 +1,2 @@
 DIST yarn-v1.22.0.tar.gz 1244012 BLAKE2B 2764704103e281de8fd8c2c28abae56c7ba863365989b884add045d2f80810f0f8b83acd77baeef2375fe1424ad54cabfd89e4d14b38068114552115d3b7a812 SHA512 28c1cffc9ab9de364a4d8f624d4b77748565fdb7ba50fb3620da3debe0676472cac583537f03269601d368c5b2199a0eef8448e00205be75a162b5ead9448992
+DIST yarn-v1.22.4.tar.gz 1244785 BLAKE2B 1f1eeb829096eaf19a8fdb48b46fa736769d9d3c247759e434413665186e4cccb750024afa836dae8a0130fc472df3c01805d263d81346e1dd7509e1b106e88a SHA512 a1833b862fe52169bd6c2a033045a07df5bc6a23595c259e675fed1b2d035ab37abe6ce309720abb6636d68f03615054b6292dc0a70da31c8697fda228b50d18
diff --git a/sys-apps/yarn/yarn-1.22.4.ebuild b/sys-apps/yarn/yarn-1.22.4.ebuild
new file mode 100644 (file)
index 0000000..7064539
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="${PN}-v${PV}"
+
+DESCRIPTION="Fast, reliable, and secure node dependency management"
+HOMEPAGE="https://yarnpkg.com"
+SRC_URI="https://github.com/yarnpkg/yarn/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!dev-util/cmdtest
+       net-libs/nodejs"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+       default
+       sed -i 's/"installationMethod": "tar"/"installationMethod": "portage"/g' "${S}/package.json" || die
+}
+
+src_install() {
+       local install_dir="/usr/$(get_libdir)/node_modules/yarn" path shebang
+       insinto "${install_dir}"
+       doins -r .
+       dosym "../$(get_libdir)/node_modules/yarn/bin/yarn.js" "/usr/bin/yarn"
+       dosym "../$(get_libdir)/node_modules/yarn/bin/yarnpkg" "/usr/bin/yarnpkg"
+
+       while read -r -d '' path; do
+               read -r shebang < "${ED}${path}" || die
+               [[ "${shebang}" == \#\!* ]] || continue
+               fperms +x "${path}"
+       done < <(find "${ED}" -type f -printf '/%P\0' || die)
+}