dev-ml/ppx_variants_conv: bump to 113.33.00
authorAlexis Ballier <aballier@gentoo.org>
Tue, 22 Mar 2016 08:51:48 +0000 (09:51 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 22 Mar 2016 09:19:58 +0000 (10:19 +0100)
Package-Manager: portage-2.2.28
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ml/ppx_variants_conv/Manifest
dev-ml/ppx_variants_conv/ppx_variants_conv-113.33.00.ebuild [new file with mode: 0644]

index ee0051fe908408b8370d545e7afbcceb459f1abd..3f105137520ac198022676e019e55800c09669ee 100644 (file)
@@ -1 +1,2 @@
 DIST ppx_variants_conv-113.24.00.tar.gz 55571 SHA256 753ee2c6c9115c4aed5069fd6792c3709bae1fa9f12356641aecd317be18ecd7 SHA512 3e4844defd3f29ee7a2435fefa3de1261e9b205700b3563f6b655d692cceaba17a3545785fd5b449d507312aa9e669b3943be3032151ea7b368f44adffaa64d5 WHIRLPOOL f11e264ddab17294eab0a779312aa0bcad8b0e06568d927fe97b2d5fd693ad56fcd5939147a162c01c00453b7d050e33a8396bcf97044ad88b1ef7c55c4578c5
+DIST ppx_variants_conv-113.33.00.tar.gz 55374 SHA256 f425d430345e1eb8c0a33c081d21c0ab0cbf1f4bffa5aad4f97f6bc2fba6d78c SHA512 df59e630f30d87da4414456380e974cb2e9ffc88c1c381edc80d012fe196a7f09956ce1654d2d73518d1bbd79e8bdc991960498130329501d81e0ca91724a4e0 WHIRLPOOL d056712c46199d738a34bf54304e2c3d76a3967f373d5b5c40dd1c8a06e8fe0bf9b409f1063b75135acd68dc21d0a6887673d4b8347dd6913110783ed7ad9985
diff --git a/dev-ml/ppx_variants_conv/ppx_variants_conv-113.33.00.ebuild b/dev-ml/ppx_variants_conv/ppx_variants_conv-113.33.00.ebuild
new file mode 100644 (file)
index 0000000..54403e9
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+DESCRIPTION="Generation of accessor and iteration functions for ocaml variant types"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-ml/ppx_tools:=
+       dev-ml/ppx_core:=
+       dev-ml/ppx_driver:=
+       dev-ml/ppx_type_conv:=
+       dev-ml/variantslib:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+       emake setup.exe
+       OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+       emake
+}
+
+src_install() {
+       opam-installer -i \
+               --prefix="${ED}/usr" \
+               --libdir="${D}/$(ocamlc -where)" \
+               --docdir="${ED}/usr/share/doc/${PF}" \
+               ${PN}.install || die
+       dodoc CHANGES.md
+}