net-misc/megatools: remove non-available configure switches and deps
authorHenning Schild <henning@hennsch.de>
Sat, 24 Mar 2018 14:47:57 +0000 (15:47 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Tue, 21 Aug 2018 14:57:20 +0000 (16:57 +0200)
Version 1.9.98 dropped fuse support and some configure switches, correct
the ebuild for that version.

Closes: https://bugs.gentoo.org/649460
Closes: https://github.com/gentoo/gentoo/pull/9033

net-misc/megatools/megatools-1.9.98.ebuild

index 42d283b633f96fe8f1d42f126b1225142a22201d..441a9ef6db3c1d5c999b1e22d76e70bcec141f4e 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -14,12 +14,11 @@ SRC_URI="https://github.com/megous/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~x86"
-IUSE="fuse introspection static-libs"
+IUSE=""
 
 COMMON_DEPEND="dev-libs/glib:2
        dev-libs/openssl:0
        net-misc/curl
-       fuse? ( sys-fs/fuse )
 "
 RDEPEND="${COMMON_DEPEND}
        net-libs/glib-networking[ssl]
@@ -30,14 +29,9 @@ DEPEND="${COMMON_DEPEND}
 
 src_configure() {
        local myeconfargs=(
-               --enable-shared
-               --enable-docs-build
                --disable-maintainer-mode
                --disable-warnings
                --disable-glibtest
-               $(use_enable static-libs static)
-               $(use_enable introspection)
-               $(use_with fuse)
        )
        autotools-utils_src_configure
 }