dev-python/beaker: Remove old
authorDavid Seifert <soap@gentoo.org>
Fri, 27 Dec 2019 18:52:13 +0000 (19:52 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 27 Dec 2019 18:52:13 +0000 (19:52 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/beaker/Manifest
dev-python/beaker/beaker-1.6.4-r1.ebuild [deleted file]

index e7e31ef310a8f439f71e296b05d23bcd28149d4d..d0c9400d7dec726df8da7daa2ef8984a0e68a032 100644 (file)
@@ -1,2 +1 @@
-DIST Beaker-1.6.4.tar.gz 54480 BLAKE2B 809b2d23fb95a21ab442b3be20ff5372630697baaf507fd26d8aefabeed422401de890c8de165a079bde4a05230cea244a8d5bf31b8b89e60a88b840de9cdedf SHA512 5a6835d01d0b1bee57844525f1223d74edd26f07cc769df6a8cfa77f44dda4435eb96639175928a1caf7c4f927ac3a674c0fd0e7f50f1aea91da7880de3a6704
 DIST beaker-1.8.1.tar.gz 80541 BLAKE2B b60ba47a41f5f039699324dcb403d99cbf3d7e7cdbf593e275e1d41e6abc86dc829fd9a582b80e6274d6459624218585239b1b623e70636e2a1d736c584ce245 SHA512 bd9c4a4bbf21749a59c50ffff1d1dbff8bc9116394f79924efc6be637fb8c1ffef91a8363da3375bffdcb0ba291b71b57f75303f3fbe111e8670a390058e9fa5
diff --git a/dev-python/beaker/beaker-1.6.4-r1.ebuild b/dev-python/beaker/beaker-1.6.4-r1.ebuild
deleted file mode 100644 (file)
index 2fbcff2..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# py3.3 unfit with some types
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_PN="Beaker"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A Session and Caching library with WSGI Middleware"
-HOMEPAGE="
-       https://github.com/bbangert/beaker
-       https://beaker.readthedocs.io/en/latest/
-       https://pypi.org/project/Beaker/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~hppa ia64 ~ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# webtest-based tests are skipped when webtest is not installed
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/webtest[${PYTHON_USEDEP}] )"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
-       # Workaround for http://bugs.python.org/issue11276.
-       sed -e "s/import anydbm/& as anydbm/;/import anydbm/a dbm = anydbm" \
-               -i beaker/container.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       cp -r -l tests "${BUILD_DIR}"/ || die
-       pushd  "${BUILD_DIR}"/tests > /dev/null
-       nosetests || die "Tests fail with ${EPYTHON}"
-       popd > /dev/null
-}