app-crypt/swtpm: Add libressl support
authorSalah Coronya <salah.coronya@gmail.com>
Mon, 13 Jan 2020 05:59:09 +0000 (23:59 -0600)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 19 Feb 2020 13:32:18 +0000 (15:32 +0200)
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Salah Coronya <salah.coronya@gmail.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-crypt/swtpm/swtpm-0.2.0-r1.ebuild [new file with mode: 0644]

diff --git a/app-crypt/swtpm/swtpm-0.2.0-r1.ebuild b/app-crypt/swtpm/swtpm-0.2.0-r1.ebuild
new file mode 100644 (file)
index 0000000..eeb7c50
--- /dev/null
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit autotools python-any-r1
+
+DESCRIPTION="Libtpms-based TPM emulator"
+HOMEPAGE="https://github.com/stefanberger/swtpm"
+SRC_URI="https://github.com/stefanberger/swtpm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="fuse gnutls libressl seccomp test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+       fuse? (
+               dev-libs/glib:2
+               sys-fs/fuse:0
+             )
+       gnutls? (
+                  dev-libs/libtasn1:=
+                  >=net-libs/gnutls-3.1.0[tools]
+               )
+       !libressl? (
+                dev-libs/openssl:0=
+                dev-libs/libtpms[-libressl]
+                  )
+       libressl? (
+                   dev-libs/libressl:0=
+                   dev-libs/libtpms[libressl]
+                 )
+       seccomp? ( sys-libs/libseccomp )
+"
+
+DEPEND="${COMMON_DEPEND}
+       test? (
+               net-misc/socat
+               ${PYTHON_DEPS}
+             )
+"
+
+RDEPEND="${COMMON_DEPEND}
+       app-crypt/tpm-tools
+       app-crypt/trousers
+       dev-tcltk/expect"
+
+src_prepare() {
+       use test || eapply "${FILESDIR}/${PN}-disable-test-dependencies.patch"
+       eapply "${FILESDIR}/${PN}-fix-localca-path.patch"
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+         --with-openssl \
+         --without-selinux \
+         $(use_with fuse cuse) \
+         $(use_with gnutls) \
+         $(use_with seccomp)
+}
+
+src_install() {
+       default
+       fowners tss:tss /var/lib/swtpm-localca
+       keepdir /var/lib/swtpm-localca
+       find "${D}" -name '*.la' -delete || die
+}