dev-python/soupsieve: Bump to 1.9.6
authorMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 16:53:25 +0000 (18:53 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 16:53:25 +0000 (18:53 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/soupsieve/Manifest
dev-python/soupsieve/soupsieve-1.9.6.ebuild [new file with mode: 0644]

index 9facd4bb0ed6974b9833353f5f054a8e6dc01acb..c68b2d46074d492a8d5f473775c9d8cae28b3cdd 100644 (file)
@@ -1 +1,2 @@
 DIST soupsieve-1.9.5.tar.gz 99119 BLAKE2B adf2f068ca536583557dff5b86fbb8020de8139c346ab124c8f78d91d2c0db49553cc9b8580a4e8af0fb74e19a8f8b6e5459b654a900034d76a677e60ea0fece SHA512 38cf37c7080ec6054291a076eb4b152bbf5267b9fed25f933a340345cd7807f14f4a5300707090fd233382e96841f6a33305876cf02740c96dd6aa9d2af06868
+DIST soupsieve-1.9.6.tar.gz 99276 BLAKE2B 2bd2f74e6974ad73c79c018f704fef600594c568471062c503a7fb1248e2cc1840011d31550f7573654f015016f0d3272778b0100e4701318a829f916f06698e SHA512 44954cdedc16a51c794ebe6770caeb8f179167ad2f0a0478cb1efd5878d6cc49fffd6119125964b19184afa6d0d7dedadb81dee020a48c5128ccf56e36a78f61
diff --git a/dev-python/soupsieve/soupsieve-1.9.6.ebuild b/dev-python/soupsieve/soupsieve-1.9.6.ebuild
new file mode 100644 (file)
index 0000000..0c89169
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A modern CSS selector implementation for BeautifulSoup"
+HOMEPAGE="https://github.com/facelessuser/soupsieve
+       https://pypi.python.org/pypi/soupsieve"
+SRC_URI="https://github.com/facelessuser/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT+=" !test? ( test )"
+
+RDEPEND="
+       $(python_gen_cond_dep 'dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]' -2)
+"
+BDEPEND="${RDEPEND}
+       test? (
+               dev-python/beautifulsoup[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep 'dev-python/lxml[${PYTHON_USEDEP}]' python2_7 'python3*')
+               dev-python/html5lib[${PYTHON_USEDEP}]
+       )
+"
+
+distutils_enable_tests pytest