sys-apps/portage: Check for CONFIG_UTS_NS
authorZac Medico <zmedico@gentoo.org>
Tue, 5 May 2020 17:13:48 +0000 (10:13 -0700)
committerZac Medico <zmedico@gentoo.org>
Tue, 5 May 2020 17:15:58 +0000 (10:15 -0700)
Reported-by: Tomek L <tomek@lutel.pl>
See: https://github.com/gentoo/portage/pull/539
Bug: https://bugs.gentoo.org/680456#c8
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Zac Medico <zmedico@gentoo.org>
sys-apps/portage/portage-2.3.99-r2.ebuild
sys-apps/portage/portage-9999.ebuild

index a8d904ae3725b5d1425bd30dd9825985a9bb83f2..91855cdabde4fe543e2db02cc7984cf5f084eaf0 100644 (file)
@@ -82,7 +82,7 @@ SRC_URI="mirror://gentoo/${PN}-${TARBALL_PV}.tar.bz2
        https://github.com/gentoo/portage/commit/9738a404e876270cbdef2514f66915bce35d7435.patch -> portage-2.3.89-bug-718578.patch"
 
 pkg_pretend() {
-       local CONFIG_CHECK="~IPC_NS ~PID_NS ~NET_NS"
+       local CONFIG_CHECK="~IPC_NS ~PID_NS ~NET_NS ~UTS_NS"
 
        check_extra_config
 }
index 7c222c5a8137e0da66f0e75f813b536b24a3a40e..f581cb8ae977b9118e574d6963a7232b41e4426f 100644 (file)
@@ -78,7 +78,7 @@ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage.git
        https://github.com/gentoo/portage.git"
 
 pkg_pretend() {
-       local CONFIG_CHECK="~IPC_NS ~PID_NS ~NET_NS"
+       local CONFIG_CHECK="~IPC_NS ~PID_NS ~NET_NS ~UTS_NS"
 
        check_extra_config
 }