sys-devel/clang: Use BDEPEND semi-properly
authorMichał Górny <mgorny@gentoo.org>
Tue, 17 Sep 2019 21:00:14 +0000 (23:00 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 17 Sep 2019 21:00:48 +0000 (23:00 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-devel/clang/clang-10.0.0.9999.ebuild
sys-devel/clang/clang-9.0.0.9999.ebuild

index 423e55170bfdc7e06118e9c796102a49af27ac9b..54f0479ac537cbe43a64af053f315f4a93163cbc 100644 (file)
@@ -40,8 +40,9 @@ RDEPEND="
        static-analyzer? ( dev-lang/perl:* )
        xml? ( dev-libs/libxml2:2=[${MULTILIB_USEDEP}] )
        ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
 # configparser-3.2 breaks the build (3.3 or none at all are fine)
-DEPEND="${RDEPEND}
+BDEPEND="
        doc? ( dev-python/sphinx )
        xml? ( virtual/pkgconfig )
        !!<dev-python/configparser-3.3.0.2
index 4fac61d4c534c574c78506de0e2310dbd4880ff0..2322c11594043d9b4ad99b551e134ddeea125625 100644 (file)
@@ -39,8 +39,9 @@ RDEPEND="
        static-analyzer? ( dev-lang/perl:* )
        xml? ( dev-libs/libxml2:2=[${MULTILIB_USEDEP}] )
        ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
 # configparser-3.2 breaks the build (3.3 or none at all are fine)
-DEPEND="${RDEPEND}
+BDEPEND="
        doc? ( dev-python/sphinx )
        xml? ( virtual/pkgconfig )
        !!<dev-python/configparser-3.3.0.2