net-dns/pdns: Add sodium USE flag, bug #639018
authorSven Wegener <swegener@gentoo.org>
Thu, 30 Nov 2017 18:28:37 +0000 (18:28 +0000)
committerSven Wegener <swegener@gentoo.org>
Thu, 30 Nov 2017 19:05:45 +0000 (19:05 +0000)
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Closes: https://bugs.gentoo.org/639018

net-dns/pdns/metadata.xml
net-dns/pdns/pdns-4.1.0_rc3-r1.ebuild

index 264c58531540edfd5d730f7d13ca2603f4c4541b..03c68c6fd1028755d5842ec7d0156f7df039aeaf 100644 (file)
@@ -18,6 +18,7 @@ standards documents. Furthermore, PowerDNS interfaces with almost any database.
        <flag name="opendbx">Use a database supported by <pkg>dev-db/opendbx</pkg> as backend.</flag>
        <flag name="protobuf">Enable support for <pkg>dev-libs/protobuf</pkg>.</flag>
        <flag name="remote">Use a generic socket or pipe as a backend (via JSON RPC requests).</flag>
+       <flag name="sodium">Use <pkg>dev-libs/libsodium</pkg> for cryptography</flag>
        <flag name="tinydns">Use a TinyDNS CDB database as backend.</flag>
        <flag name="tools">Build optional tools (dnsscan, dnsscope, etc..).</flag>
 </use>
index 06d462d4a73515b218fb834302f1b2fc5cd65c26..d97d257344e6444ada6eb2bc5a286ea8abcfb5e8 100644 (file)
@@ -18,7 +18,7 @@ KEYWORDS="~amd64 ~x86"
 # oracle: dito (need Oracle Client Libraries)
 # xdb: (almost) dead, surely not supported
 
-IUSE="botan debug doc geoip ldap libressl lua luajit mydns mysql opendbx postgres protobuf remote sqlite systemd tools tinydns test"
+IUSE="botan debug doc geoip ldap libressl lua luajit mydns mysql opendbx postgres protobuf remote sodium sqlite systemd tools tinydns test"
 
 REQUIRED_USE="mydns? ( mysql ) ?? ( lua luajit )"
 
@@ -35,6 +35,7 @@ RDEPEND="
        sqlite? ( dev-db/sqlite:3 )
        opendbx? ( dev-db/opendbx )
        geoip? ( >=dev-cpp/yaml-cpp-0.5.1 dev-libs/geoip )
+       sodium? ( dev-libs/libsodium:= )
        tinydns? ( >=dev-db/tinycdb-0.77 )
        protobuf? ( dev-libs/protobuf )"
 DEPEND="${RDEPEND}
@@ -76,6 +77,7 @@ src_configure() {
                $(use_enable test unit-tests) \
                $(use_enable tools) \
                $(use_enable systemd) \
+               $(use_enable sodium libsodium) \
                $(use_with lua) \
                $(use_with luajit) \
                $(use_with protobuf) \