dev-libs/rocr-runtime: Remove unused patches
authorCraig Andrews <candrews@gentoo.org>
Thu, 2 Jan 2020 12:58:45 +0000 (07:58 -0500)
committerCraig Andrews <candrews@gentoo.org>
Thu, 2 Jan 2020 12:58:45 +0000 (07:58 -0500)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Craig Andrews <candrews@gentoo.org>
dev-libs/rocr-runtime/files/rocr-runtime-2.0.0-cmake-install-paths.patch [deleted file]
dev-libs/rocr-runtime/files/rocr-runtime-2.8.0-fix_doorbell_map.patch [deleted file]

diff --git a/dev-libs/rocr-runtime/files/rocr-runtime-2.0.0-cmake-install-paths.patch b/dev-libs/rocr-runtime/files/rocr-runtime-2.0.0-cmake-install-paths.patch
deleted file mode 100644 (file)
index 2caeebb..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-https://github.com/RadeonOpenCompute/ROCR-Runtime/pull/51/
-
-commit 2d51a6133f32b72f60fba0e95234aee2b63aa682 (HEAD -> patch-6)
-Author: Craig Andrews <candrews@integralblue.com>
-Date:   Mon Jan 7 21:06:14 2019 -0500
-
-    Correctly install the library into the system
-    
-    Install to standard locations in /usr/{lib,include}/lib (as opposed to /usr/hsa/{lib,include}/hsa)
-    Use CMAKE_INSTALL_LIBDIR and CMAKE_INSTALL_INCLUDEDIR from GNUInstallDirs instead of using "lib" and "include"
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 37a9b09..545f183 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -53,6 +53,7 @@ project( ${CORE_RUNTIME_TARGET} )
- list ( APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake_modules" )
- include ( utils )
-+include ( GNUInstallDirs )
- include ( hsa_common )
- ## Find LibElf
-@@ -176,15 +177,9 @@ if ( "${CMAKE_BUILD_TYPE}" STREQUAL Release )
-     add_custom_command ( TARGET ${CORE_RUNTIME_TARGET} POST_BUILD COMMAND ${CMAKE_STRIP} *.so )
- endif ()
--## Create symlinks for packaging and install
--add_custom_target ( hsa-link ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../hsa/include/hsa hsa-link )
--add_custom_target ( ${CORE_RUNTIME_TARGET}.so-link ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../hsa/lib/${CORE_RUNTIME_LIBRARY}.so ${CORE_RUNTIME_LIBRARY}.so-link )
--
- ## Set install information
--install ( TARGETS ${CORE_RUNTIME_TARGET} LIBRARY DESTINATION hsa/lib )
--install ( DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/inc/ DESTINATION hsa/include/hsa )
--install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/hsa-link DESTINATION include PERMISSIONS OWNER_WRITE OWNER_READ RENAME hsa )
--install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/${CORE_RUNTIME_LIBRARY}.so-link DESTINATION lib PERMISSIONS OWNER_WRITE OWNER_READ RENAME ${CORE_RUNTIME_LIBRARY}.so )
-+install ( TARGETS ${CORE_RUNTIME_TARGET} LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} )
-+install ( DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/inc/ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/hsa )
- ## Packaging directives
- set ( CPACK_PACKAGE_NAME "hsa-rocr-dev" )
-
diff --git a/dev-libs/rocr-runtime/files/rocr-runtime-2.8.0-fix_doorbell_map.patch b/dev-libs/rocr-runtime/files/rocr-runtime-2.8.0-fix_doorbell_map.patch
deleted file mode 100644 (file)
index aef3d29..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-https://github.com/RadeonOpenCompute/ROCR-Runtime/pull/71
-
-From d2a6ad97eb96a28d8f8b658b26ab94e911886cf2 Mon Sep 17 00:00:00 2001
-From: Sean Keely <Sean.Keely@amd.com>
-Date: Thu, 5 Sep 2019 20:58:57 -0500
-Subject: [PATCH] Correct doorbell_queue_map allocation.
-
-doorbell_queue_map should be allocated unconditionally.
----
- core/runtime/amd_gpu_agent.cpp | 22 +++++++++++-----------
- 1 file changed, 11 insertions(+), 11 deletions(-)
-
-diff --git a/core/runtime/amd_gpu_agent.cpp b/core/runtime/amd_gpu_agent.cpp
-index 9b79a6b..76df913 100644
---- a/core/runtime/amd_gpu_agent.cpp
-+++ b/core/runtime/amd_gpu_agent.cpp
-@@ -1182,12 +1182,22 @@ void GpuAgent::SyncClocks() {
- }
- void GpuAgent::BindTrapHandler() {
-+  // Make an empty map from doorbell index to queue.
-+  // The trap handler uses this to retrieve a wave's amd_queue_t*.
-+  auto doorbell_queue_map_size = MAX_NUM_DOORBELLS * sizeof(amd_queue_t*);
-+
-+  doorbell_queue_map_ = (amd_queue_t**)core::Runtime::runtime_singleton_->system_allocator()(
-+      doorbell_queue_map_size, 0x1000, 0);
-+  assert(doorbell_queue_map_ != NULL && "Doorbell queue map allocation failed");
-+
-+  memset(doorbell_queue_map_, 0, doorbell_queue_map_size);
-+
-   if (isa_->GetMajorVersion() == 7) {
-     // No trap handler support on Gfx7, soft error.
-     return;
-   }
--  // Disable trap handler on Carrizo until KFD is fixed.
-+  // Disable trap handler on APUs until KFD is fixed.
-   if (profile_ == HSA_PROFILE_FULL) {
-     return;
-   }
-@@ -1195,16 +1205,6 @@ void GpuAgent::BindTrapHandler() {
-   // Assemble the trap handler source code.
-   AssembleShader("TrapHandler", AssembleTarget::ISA, trap_code_buf_, trap_code_buf_size_);
--  // Make an empty map from doorbell index to queue.
--  // The trap handler uses this to retrieve a wave's amd_queue_t*.
--  auto doorbell_queue_map_size = MAX_NUM_DOORBELLS * sizeof(amd_queue_t*);
--
--  doorbell_queue_map_ = (amd_queue_t**)core::Runtime::runtime_singleton_->system_allocator()(
--      doorbell_queue_map_size, 0x1000, 0);
--  assert(doorbell_queue_map_ != NULL && "Doorbell queue map allocation failed");
--
--  memset(doorbell_queue_map_, 0, doorbell_queue_map_size);
--
-   // Bind the trap handler to this node.
-   HSAKMT_STATUS err = hsaKmtSetTrapHandler(node_id(), trap_code_buf_, trap_code_buf_size_,
-                                            doorbell_queue_map_, doorbell_queue_map_size);