x11-plugins/wmSpaceWeather: fix build with -fno-common
authorBernard Cafarelli <voyageur@gentoo.org>
Sun, 1 Mar 2020 15:20:58 +0000 (16:20 +0100)
committerBernard Cafarelli <voyageur@gentoo.org>
Sun, 1 Mar 2020 15:20:58 +0000 (16:20 +0100)
Closes: https://bugs.gentoo.org/707600
Package-Manager: Portage-2.3.90, Repoman-2.3.20
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
x11-plugins/wmSpaceWeather/files/wmSpaceWeather-1.04_p19-gcc-10.patch [new file with mode: 0644]
x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild

diff --git a/x11-plugins/wmSpaceWeather/files/wmSpaceWeather-1.04_p19-gcc-10.patch b/x11-plugins/wmSpaceWeather/files/wmSpaceWeather-1.04_p19-gcc-10.patch
new file mode 100644 (file)
index 0000000..f95e7e5
--- /dev/null
@@ -0,0 +1,23 @@
+diff -Naur wmspaceweather-1.04.orig.orig/wmgeneral/wmgeneral.h wmspaceweather-1.04.orig/wmgeneral/wmgeneral.h
+--- wmspaceweather-1.04.orig.orig/wmgeneral/wmgeneral.h        1999-04-11 07:35:53.000000000 +0200
++++ wmspaceweather-1.04.orig/wmgeneral/wmgeneral.h     2020-03-01 16:13:29.843346352 +0100
+@@ -28,7 +28,7 @@
+  /* Global variable */
+ /*******************/
+-Display               *display;
++extern Display                *display;
+   /***********************/
+  /* Function Prototypes */
+diff -Naur wmspaceweather-1.04.orig.orig/wmSpaceWeather/wmSpaceWeather.c wmspaceweather-1.04.orig/wmSpaceWeather/wmSpaceWeather.c
+--- wmspaceweather-1.04.orig.orig/wmSpaceWeather/wmSpaceWeather.c      1999-04-11 07:35:53.000000000 +0200
++++ wmspaceweather-1.04.orig/wmSpaceWeather/wmSpaceWeather.c   2020-03-01 16:13:38.172348429 +0100
+@@ -91,6 +91,7 @@
+ char            URL[1024];
+ int           ForceUpdate2;
++Display               *display;
+ void ParseCMDLine(int argc, char *argv[]);
+ void pressEvent(XButtonEvent *xev);
index 568c3f7524fb7bf418778fa3e3fa79f60cecfa22..9bd5996db7f1ed245d66a51c4b77c4d68719a7ea 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -36,6 +36,7 @@ S="${WORKDIR}/${MY_P_ORIG/_/-}/${PN}"
 src_unpack() {
        unpack ${MY_P_ORIG}.tar.gz
        epatch "${DISTDIR}"/${MY_P_PATCH}.gz
+       epatch "${FILESDIR}"/${P}-gcc-10.patch
 
        # need to apply patches from Debian first, do NOT change the order
        cd "${S}" || die