media-libs/libmatemixer: Bump to 1.24.0
authorAdam Feldman <NP-Hardass@gentoo.org>
Thu, 19 Mar 2020 20:35:24 +0000 (16:35 -0400)
committerAdam Feldman <NP-Hardass@gentoo.org>
Mon, 6 Apr 2020 17:47:57 +0000 (13:47 -0400)
Package-Manager: Portage-2.3.82, Repoman-2.3.18
Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
media-libs/libmatemixer/Manifest
media-libs/libmatemixer/libmatemixer-1.22.0.ebuild
media-libs/libmatemixer/libmatemixer-1.24.0.ebuild [new file with mode: 0644]

index 649068104bc3733dffcd6542361589d71e24539a..55e08a758483ddba80f54ecb4a1a3afc7427c5cb 100644 (file)
@@ -1 +1,2 @@
 DIST libmatemixer-1.22.0.tar.xz 432592 BLAKE2B 36f16c0ed516dea05368ae5b4f287cce275844b547fb7eebe7fb0604d0fddce72649dcac1c16475539dc5199f5d310b8bd19f165efd4bfa5c4f1bf31c1141df7 SHA512 6eaa006142601c077ac70739e637273288a4b9713dfc4179341c4832ae4e3b362e92104e150132ee274224d6c5dc057d812b7e1814e49a7690581de6d81e0db8
+DIST libmatemixer-1.24.0.tar.xz 484808 BLAKE2B 8527514cec0770381ce5943f8c87e66f101e92f34527af2b3d4c15696f63df8304f00102fbbfe5b98ebb9b8d8b515f64a3d63b53312f7892b1b4868895539a6f SHA512 bf8c807bd45f3626bbf881eefa1e4638165daf61637bc63a704492d2a67eeec622e35e58c041649d33411294f96f79c99b3ea2406ae6fcf83294ec625cca9dbf
index 3bb4a5033c0c59999d5cd1a5d2c9d149bba58e50..2797c67b6f1c19f3a88811374df75ab5e6865108 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
diff --git a/media-libs/libmatemixer/libmatemixer-1.24.0.ebuild b/media-libs/libmatemixer/libmatemixer-1.24.0.ebuild
new file mode 100644 (file)
index 0000000..ca97e73
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+       KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Mixer library for MATE Desktop"
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="+alsa oss pulseaudio"
+
+COMMON_DEPEND="
+       >=dev-libs/glib-2.50:2
+       >=sys-devel/gettext-0.19.8:*
+       alsa? ( >=media-libs/alsa-lib-1.0.5 )
+       pulseaudio? ( >=media-sound/pulseaudio-5.0.0:0[alsa?,glib] )
+"
+
+RDEPEND="${COMMON_DEPEND}
+       virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+       app-text/docbook-xml-dtd:4.1.2
+       dev-util/gtk-doc
+       dev-util/gtk-doc-am
+       virtual/pkgconfig:*
+"
+
+src_configure() {
+       mate_src_configure \
+               --disable-null \
+               $(use_enable alsa) \
+               $(use_enable oss) \
+               $(use_enable pulseaudio)
+}