app-crypt/tpm2-totp: initial add
authorAlon Bar-Lev <alonbl@gentoo.org>
Thu, 30 May 2019 23:11:29 +0000 (02:11 +0300)
committerAlon Bar-Lev <alonbl@gentoo.org>
Thu, 30 May 2019 23:46:17 +0000 (02:46 +0300)
Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

app-crypt/tpm2-totp/Manifest [new file with mode: 0644]
app-crypt/tpm2-totp/files/tpm2-totp-0.1.1-build.patch [new file with mode: 0644]
app-crypt/tpm2-totp/metadata.xml [new file with mode: 0644]
app-crypt/tpm2-totp/tpm2-totp-0.1.1.ebuild [new file with mode: 0644]

diff --git a/app-crypt/tpm2-totp/Manifest b/app-crypt/tpm2-totp/Manifest
new file mode 100644 (file)
index 0000000..4c6b8de
--- /dev/null
@@ -0,0 +1 @@
+DIST tpm2-totp-0.1.1.tar.gz 357787 BLAKE2B c7a24b30c155cfd5387180a2c8584497327eadd701068aa5eb3c385bbadf26f448f88c238849fbf68c4e7265f01d3783b3aa50a912070df1c2fd4485310f2299 SHA512 33a4af16a292ddd674a399bf12ce0b355d95de7014e8be11816a1d88edfd36ae222a8b7508f3aa1be3b46c7e04bf2712ee4839cf9f4f83fc308cb4f639ec5b9f
diff --git a/app-crypt/tpm2-totp/files/tpm2-totp-0.1.1-build.patch b/app-crypt/tpm2-totp/files/tpm2-totp-0.1.1-build.patch
new file mode 100644 (file)
index 0000000..232b4f9
--- /dev/null
@@ -0,0 +1,70 @@
+From 2652497a15572d2484f57fee8be252d0d5fe4f8c Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Fri, 31 May 2019 01:39:29 +0300
+Subject: [PATCH] build: add --disable-defaultflags
+
+Align with tpm2-tss to allow downstream to provide flags.
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ configure.ac | 42 +++++++++++++++++++++++++-----------------
+ 1 file changed, 25 insertions(+), 17 deletions(-)
+
+https://github.com/tpm2-software/tpm2-totp/pull/39
+
+diff --git a/configure.ac b/configure.ac
+index baf596b..ac11e1e 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -47,23 +47,31 @@ AC_SUBST([LIBEXECDIR])
+ AC_CONFIG_FILES([Makefile dist/tpm2-totp.pc dist/dracut/module-setup.sh dist/initcpio/install/plymouth-tpm2-totp])
+-AX_ADD_COMPILER_FLAG([-std=c99])
+-AX_ADD_COMPILER_FLAG([-Wall])
+-AX_ADD_COMPILER_FLAG([-Wextra])
+-AX_ADD_COMPILER_FLAG([-Wformat-security])
+-AX_ADD_COMPILER_FLAG([-Werror])
+-AX_ADD_COMPILER_FLAG([-fstack-protector-all])
+-AX_ADD_COMPILER_FLAG([-fpic])
+-AX_ADD_COMPILER_FLAG([-fPIC])
+-
+-# work around GCC bug #53119
+-#   https://gcc.gnu.org/bugzilla/show_bug.cgi?id=53119
+-AX_ADD_COMPILER_FLAG([-Wno-missing-braces])
+-
+-AX_ADD_LINK_FLAG([-Wl,--no-undefined])
+-AX_ADD_LINK_FLAG([-Wl,-z,noexecstack])
+-AX_ADD_LINK_FLAG([-Wl,-z,now])
+-AX_ADD_LINK_FLAG([-Wl,-z,relro])
++AC_ARG_ENABLE([defaultflags],
++              [AS_HELP_STRING([--disable-defaultflags],
++                              [Disable default preprocessor, compiler, and linker flags.])],
++              [enable_defaultflags=$enableval],
++              [enable_defaultflags=yes])
++AS_IF([test "x$enable_defaultflags" = "xyes"],
++      [
++      AX_ADD_COMPILER_FLAG([-std=c99])
++      AX_ADD_COMPILER_FLAG([-Wall])
++      AX_ADD_COMPILER_FLAG([-Wextra])
++      AX_ADD_COMPILER_FLAG([-Wformat-security])
++      AX_ADD_COMPILER_FLAG([-Werror])
++      AX_ADD_COMPILER_FLAG([-fstack-protector-all])
++      AX_ADD_COMPILER_FLAG([-fpic])
++      AX_ADD_COMPILER_FLAG([-fPIC])
++
++      # work around GCC bug #53119
++      #   https://gcc.gnu.org/bugzilla/show_bug.cgi?id=53119
++      AX_ADD_COMPILER_FLAG([-Wno-missing-braces])
++
++      AX_ADD_LINK_FLAG([-Wl,--no-undefined])
++      AX_ADD_LINK_FLAG([-Wl,-z,noexecstack])
++      AX_ADD_LINK_FLAG([-Wl,-z,now])
++      AX_ADD_LINK_FLAG([-Wl,-z,relro])
++      ])
+ AX_CODE_COVERAGE
+ m4_ifdef([_AX_CODE_COVERAGE_RULES],
+-- 
+2.21.0
+
diff --git a/app-crypt/tpm2-totp/metadata.xml b/app-crypt/tpm2-totp/metadata.xml
new file mode 100644 (file)
index 0000000..0509d46
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>crypto@gentoo.org</email>
+               <name>Crypto</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">tpm2-software/tpm2-totp</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/app-crypt/tpm2-totp/tpm2-totp-0.1.1.ebuild b/app-crypt/tpm2-totp/tpm2-totp-0.1.1.ebuild
new file mode 100644 (file)
index 0000000..8b2622c
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Attest the trustworthiness of a device against a human using time-based OTP"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-totp"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=app-crypt/tpm2-tss-2.0:=
+       media-gfx/qrencode:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+       "${FILESDIR}/${P}-build.patch"
+)
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               --disable-defaultflags
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+}