media-video/cinelerra: Bump to CinCV 2.3 (need to change versionning when this gets...
authorAlexis Ballier <aballier@gentoo.org>
Sun, 22 Jan 2017 18:45:54 +0000 (19:45 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Sun, 22 Jan 2017 18:46:12 +0000 (19:46 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

media-video/cinelerra/Manifest
media-video/cinelerra/cinelerra-20150908.ebuild [new file with mode: 0644]
media-video/cinelerra/files/cinelerra-implicit_decls.patch [new file with mode: 0644]

index a2c9b676a34979d09d6de070fb9e16aeaf33048b..50ddd08c77984e581e97cf891f7f0c09903e81eb 100644 (file)
@@ -1 +1,2 @@
 DIST cinelerra-20140710.tar.xz 24843336 SHA256 3a7c72e68c7fa8d20f0186bd9460453973e2ffdccc9e0fff1fd9114610361ff2 SHA512 ede8e3888c24022802b45909b8977ec449262f17bd488bf1fab9885b3cb76fa0a66f82e780e204bde2cd3e1da2952aec927d733f21b9883601f128478eeb81db WHIRLPOOL cf56e7f3531ff4f6e2d350bb5fc247f71106f60f016dc20fc7e73556cd05dd97c812b61709109210f76e30c67552e03f9927a52e92f6ce6d83227438cdc4314b
+DIST cinelerra-20150908.tar.xz 25705608 SHA256 4bcb450347de5eccea0ed6d49d6d70e4b065905516e4416f9a788d0d7ccc926f SHA512 908dc097af8507e3b60b4787e0350500b8ba8c4340bbbdbf3716e61d74074e5f0617500b94ed1d450e030f88f3821f948cfa37c247ec2c2571fd76974374868e WHIRLPOOL 52a74c74cfeacbebd3cf3e2aced7a0054b68ce3ec04309ac608c4e1e5779a9ced8d9ea50a0898b610288aef588b613455b38b46af3ab67c44f3581ef3676b79e
diff --git a/media-video/cinelerra/cinelerra-20150908.ebuild b/media-video/cinelerra/cinelerra-20150908.ebuild
new file mode 100644 (file)
index 0000000..e31d0c4
--- /dev/null
@@ -0,0 +1,118 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils multilib flag-o-matic
+
+CINCV_VER=2.3
+
+DESCRIPTION="The most advanced non-linear video editor and compositor"
+HOMEPAGE="http://www.cinelerra.org/"
+SRC_URI="https://cinelerra-cv.org/releases/CinelerraCV-${CINCV_VER}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="cpu_flags_x86_3dnow alsa altivec css debug ieee1394 cpu_flags_x86_mmx opengl oss"
+
+RDEPEND="media-libs/a52dec:=
+       media-libs/faac:=
+       media-libs/faad2:=
+       >=media-libs/freetype-2
+       media-libs/fontconfig
+       media-libs/libdv:=
+       >=media-libs/libogg-1.2:=
+       media-libs/libpng:0=
+       media-libs/libsndfile:=
+       >=media-libs/libtheora-1.1:=
+       >=media-libs/libvorbis-1.3:=
+       >=media-libs/openexr-1.5:=
+       media-libs/tiff:0=
+       media-libs/x264:=
+       media-sound/lame:=
+       >=media-video/mjpegtools-2
+       >=sci-libs/fftw-3
+       x11-libs/libX11:=
+       x11-libs/libXext:=
+       x11-libs/libXft:=
+       x11-libs/libXv:=
+       x11-libs/libXvMC:=
+       x11-libs/libXxf86vm:=
+       virtual/ffmpeg
+       || ( media-video/ffmpeg:0 media-libs/libpostproc )
+       virtual/jpeg:0
+       alsa? ( media-libs/alsa-lib:= )
+       ieee1394? (
+               media-libs/libiec61883:=
+               >=sys-libs/libraw1394-1.2.0:=
+               >=sys-libs/libavc1394-0.5.0:=
+               )
+       opengl? (
+               virtual/glu
+               virtual/opengl
+               )"
+DEPEND="${RDEPEND}
+       app-arch/xz-utils
+       virtual/pkgconfig
+       cpu_flags_x86_mmx? ( dev-lang/nasm )"
+
+S="${WORKDIR}/CinelerraCV-${CINCV_VER}"
+
+src_prepare() {
+       epatch \
+               "${FILESDIR}"/${PN}-20140710-validate_desktop_entry.patch \
+               "${FILESDIR}"/${PN}-ffmpeg.patch \
+               "${FILESDIR}"/${PN}-20140710-underlinking.patch \
+               "${FILESDIR}"/${PN}-20140710-ffmpeg-0.11.patch \
+               "${FILESDIR}"/${PN}-libav9.patch \
+               "${FILESDIR}"/${PN}-pngtoh.patch \
+               "${FILESDIR}"/${PN}-putbits-gcc52.patch \
+               "${FILESDIR}"/${PN}-implicit_decls.patch
+
+       if has_version '>=media-video/ffmpeg-2' ; then
+               epatch "${FILESDIR}"/${PN}-ffmpeg2.patch
+       fi
+
+       if has_version '>=media-video/ffmpeg-2.9' ; then
+               epatch "${FILESDIR}"/${PN}-ffmpeg29.patch
+       fi
+
+       eautoreconf
+}
+
+src_configure() {
+       append-cppflags -D__STDC_CONSTANT_MACROS #321945
+       append-ldflags -Wl,-z,noexecstack #212959
+
+       local myconf
+       use debug && myconf='--enable-x-error-output'
+
+       econf \
+               $(use_enable oss) \
+               $(use_enable alsa) \
+               --disable-esd \
+               $(use_enable ieee1394 firewire) \
+               $(use_enable css) \
+               $(use_enable cpu_flags_x86_mmx mmx) \
+               $(use_enable cpu_flags_x86_3dnow 3dnow) \
+               $(use_enable altivec) \
+               $(use_enable opengl) \
+               --with-plugindir=/usr/$(get_libdir)/${PN} \
+               --with-buildinfo=cust/"Gentoo - ${PV}" \
+               --with-external-ffmpeg \
+               ${myconf}
+}
+
+src_install() {
+       emake DESTDIR="${D}" install
+       dohtml -a png,html,texi,sdw -r doc/*
+
+       rm -rf "${D}"/usr/include
+       mv -vf "${D}"/usr/bin/mpeg3cat{,.hv} || die
+       mv -vf "${D}"/usr/bin/mpeg3dump{,.hv} || die
+       mv -vf "${D}"/usr/bin/mpeg3toc{,.hv} || die
+       dosym /usr/bin/mpeg2enc /usr/$(get_libdir)/${PN}/mpeg2enc.plugin
+
+       prune_libtool_files --all
+}
diff --git a/media-video/cinelerra/files/cinelerra-implicit_decls.patch b/media-video/cinelerra/files/cinelerra-implicit_decls.patch
new file mode 100644 (file)
index 0000000..c806715
--- /dev/null
@@ -0,0 +1,36 @@
+Index: CinelerraCV-2.3/quicktime/graphics.c
+===================================================================
+--- CinelerraCV-2.3.orig/quicktime/graphics.c
++++ CinelerraCV-2.3/quicktime/graphics.c
+@@ -1,5 +1,6 @@
+ #include "graphics.h"
++#include <stdlib.h>
+ #include <string.h>
+ /* Graphics acceleration routines */
+Index: CinelerraCV-2.3/quicktime/libmjpeg.c
+===================================================================
+--- CinelerraCV-2.3.orig/quicktime/libmjpeg.c
++++ CinelerraCV-2.3/quicktime/libmjpeg.c
+@@ -17,6 +17,8 @@
+  
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
++#include <strings.h>
+ #include "colormodels.h"
+ #include "libmjpeg.h"
+Index: CinelerraCV-2.3/quicktime/qtpng.c
+===================================================================
+--- CinelerraCV-2.3.orig/quicktime/qtpng.c
++++ CinelerraCV-2.3/quicktime/qtpng.c
+@@ -1,6 +1,7 @@
+ #include "colormodels.h"
+ #include "funcprotos.h"
+ #include <png.h>
++#include <string.h>
+ #include "quicktime.h"
+ #include "qtpng.h"