dev-libs/libspt: add suid USE flag
authorAkinori Hattori <hattya@gentoo.org>
Sat, 8 Jul 2017 08:38:55 +0000 (17:38 +0900)
committerAkinori Hattori <hattya@gentoo.org>
Sat, 8 Jul 2017 08:38:55 +0000 (17:38 +0900)
Package-Manager: Portage-2.3.6, Repoman-2.3.1

dev-libs/libspt/libspt-1.1-r3.ebuild [new file with mode: 0644]

diff --git a/dev-libs/libspt/libspt-1.1-r3.ebuild b/dev-libs/libspt/libspt-1.1-r3.ebuild
new file mode 100644 (file)
index 0000000..00623ec
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Library for handling root privilege"
+#HOMEPAGE="http://www.j10n.org/libspt/index.html"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="suid"
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${PN}-gentoo.patch" )
+
+src_install() {
+       default
+
+       if use suid; then
+               fperms 4755 /usr/libexec/sptagent
+       fi
+}