app-shells/bashdb: EAPI 5 bump.
authorPatrice Clement <monsieurp@gentoo.org>
Sun, 30 Aug 2015 20:18:51 +0000 (20:18 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Sun, 30 Aug 2015 20:21:42 +0000 (20:21 +0000)
Package-Manager: portage-2.2.18
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
app-shells/bashdb/bashdb-4.3.0.91-r1.ebuild [new file with mode: 0644]

diff --git a/app-shells/bashdb/bashdb-4.3.0.91-r1.ebuild b/app-shells/bashdb/bashdb-4.3.0.91-r1.ebuild
new file mode 100644 (file)
index 0000000..3fa379e
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_P="${PN}-${PV:0:3}-${PV:4}"
+DESCRIPTION="bash source code debugging"
+HOMEPAGE="http://bashdb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bashdb/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="!>=app-shells/bash-${PV:0:1}.$((${PV:2:1}+1))"
+
+S=${WORKDIR}/${MY_P}
+
+# Unfortunately, not all tests pass.
+RESTRICT='test'
+
+src_prepare() {
+       # We don't install this, so don't bother building it. #468044
+       sed -i 's:texi2html:true:' doc/Makefile.in || die
+}