dev-python/async_timeout: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 10:05:32 +0000 (11:05 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 10:08:15 +0000 (11:08 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/async_timeout/Manifest
dev-python/async_timeout/async_timeout-2.0.1.ebuild [deleted file]

index eb9bc6d772a8480c264339d58bff5d25019ff333..f929a7fd11ef60552d6a664aa0dd6335d7fc088b 100644 (file)
@@ -1,2 +1 @@
-DIST async-timeout-2.0.1.tar.gz 10463 BLAKE2B a9c1ab7ffd249f1d4d07a37f07743923a890d11bb9ff913b37f45e9f7be1110eba9cd24ce741b71a353ae349aceccd66a1853ed985416a85cdb4faa46f341681 SHA512 cb66bdc286082ef5570a7e3aa420434f82bb4131e9527c499c693a21d72b3f3772922c0ce2ad68e7de5f95960061e508effda56be398356ea75d55272f534a86
 DIST async-timeout-3.0.1.tar.gz 9724 BLAKE2B f18ae75969b7048469fe22949f25ea25da3fdbf08b98a16b5d5ffe823060a75e6de9ed764727e08d4344c79426e9c89013d49522f20ed62e6fbe912b5c7a8787 SHA512 fd30842671a79edfd52c7350e7fb2120533a6d97b44975f7b071ce2cbde43443bd5bbe1f2ad0ad3ab2156e1987b9e58e0c149b0ecfea8674eb0cb78eee79c986
diff --git a/dev-python/async_timeout/async_timeout-2.0.1.ebuild b/dev-python/async_timeout/async_timeout-2.0.1.ebuild
deleted file mode 100644 (file)
index b27f94d..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-MY_P=${PN/_/-}-${PV}
-DESCRIPTION="Timeout context manager for asyncio programs"
-HOMEPAGE="https://github.com/aio-libs/async-timeout"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-S=${WORKDIR}/${MY_P}
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       dev-python/setuptools_scm[${PYTHON_USEDEP}]
-       test? (
-               <dev-python/aiohttp-3.3[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               <dev-python/pytest-aiohttp-0.3[${PYTHON_USEDEP}]
-       )"
-
-python_prepare_all() {
-       # remove pointless dep on pytest-cov
-       sed -i -e '/addopts/d' setup.cfg || die
-       # tests fail due to missing fixture when trying to load this file
-       rm tests/conftest.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       pytest -vv || die "Tests fail with ${EPYTHON}"
-}