sys-boot/palo: Fix compiling ipl with GCC 10
authorJeroen Roovers <jer@gentoo.org>
Wed, 20 May 2020 09:55:43 +0000 (11:55 +0200)
committerJeroen Roovers <jer@gentoo.org>
Wed, 20 May 2020 09:56:22 +0000 (11:56 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Bug: https://bugs.gentoo.org/724264
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
sys-boot/palo/files/palo-2.12-gcc10.patch [new file with mode: 0644]
sys-boot/palo/palo-2.12-r1.ebuild [new file with mode: 0644]

diff --git a/sys-boot/palo/files/palo-2.12-gcc10.patch b/sys-boot/palo/files/palo-2.12-gcc10.patch
new file mode 100644 (file)
index 0000000..7832fbe
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/ipl/Makefile
++++ b/ipl/Makefile
+@@ -39,7 +39,7 @@ endif
+ VPATH=../lib:.
+ AFLAGS        = -I../lib
+-CFLAGS        = -DIPL_LOADER -I. -I../lib -I../include -O2 -mdisable-fpregs -Wall -fno-delete-null-pointer-checks
++CFLAGS        = -DIPL_LOADER -I. -I../lib -I../include -O2 -mdisable-fpregs -Wall -fno-delete-null-pointer-checks -fno-builtin
+ LDFLAGS  = -N --section-start .init=0x60000 -e '$$START$$'
+ all:  iplelf
diff --git a/sys-boot/palo/palo-2.12-r1.ebuild b/sys-boot/palo/palo-2.12-r1.ebuild
new file mode 100644 (file)
index 0000000..f2982bf
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/ https://parisc.wiki.kernel.org/"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/${PN}.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.00-toolchain.patch
+       "${FILESDIR}"/${PN}-2.12-gcc10.patch
+)
+
+src_compile() {
+       local target
+       for target in '-C palo' '-C ipl' 'iplboot'; do
+               emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) ${target}
+       done
+}
+
+src_install() {
+       into /
+       dosbin palo/palo
+
+       insinto /usr/share/palo
+       doins iplboot
+
+       insinto /etc
+       doins "${FILESDIR}"/palo.conf
+
+       insinto /etc/kernel/postinst.d
+       insopts -m 0744
+       doins "${FILESDIR}"/99palo
+
+       doman palo.8
+
+       dodoc TODO debian/changelog README.html
+}