dev-java/rome: Fix the jdom-1.0 reference that wltjr missed
authorJames Le Cuirot <chewi@gentoo.org>
Tue, 29 Sep 2015 21:11:11 +0000 (22:11 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Tue, 29 Sep 2015 21:19:57 +0000 (22:19 +0100)
Also change the src_unpack to java_prepare and use classpath rewriting
to avoid explicit dependency on junit.

Package-Manager: portage-2.2.20.1

dev-java/rome/rome-0.9-r1.ebuild

index cb20ae05d18d7489409729af7e7450aca8d2ca5d..30702d286ee880ab712552873c28cd774dbc1c7e 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -20,22 +20,20 @@ IUSE=""
 COMMON_DEPEND="dev-java/jdom:0"
 DEPEND=">=virtual/jdk-1.4
        app-arch/unzip
-       test? ( dev-java/ant-junit )
+       test? ( dev-java/ant-junit:0 )
        ${COMMON_DEPEND}"
 RDEPEND=">=virtual/jre-1.4
        ${COMMON_DEPEND}"
 
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="jdom"
 
+java_prepare() {
        # Patch build.xml so the tests pass
        epatch "${FILESDIR}/${P}-build.xml-test-upstream.patch"
 
-       # Symlink jars
-       mkdir -p target/lib
-       cd target/lib
-       java-pkg_jar-from jdom-1.0
+       # Keep Ant happy.
+       mkdir -p target/lib || die
 }
 
 src_install() {
@@ -46,6 +44,5 @@ src_install() {
 }
 
 src_test() {
-       java-pkg_jar-from --into target/lib junit
-       ANT_TASKS="ant-junit" eant test
+       java-pkg-2_src_test
 }