dev-python/python-ntpdshm: Remove Py2
authorDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:15:21 +0000 (17:15 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:15:21 +0000 (17:15 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/python-ntpdshm/python-ntpdshm-0.2.1.ebuild

index 6f3c061f3c0b728ae060daaffe3600702f4b5aee..46464d6ff93a370f90408c30b15cdebb3e11b9e0 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6}} pypy )
+PYTHON_COMPAT=( python3_{5,6} )
 
 inherit distutils-r1
 
@@ -15,7 +15,8 @@ SRC_URI="${HOMEPAGE}/archive/0.2.1.tar.gz -> ${P}.tar.gz"
 LICENSE="BSD-2"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE=""
+# tests may break running ntpd!
+RESTRICT="test"
 
 DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]
@@ -25,6 +26,3 @@ src_prepare() {
        emake swig
        distutils-r1_src_prepare
 }
-
-# tests may break running ntpd!
-RESTRICT="test"