app-admin/terraform: drop old
authorTomáš Mózes <hydrapolic@gmail.com>
Fri, 21 Feb 2020 08:22:18 +0000 (09:22 +0100)
committerMikle Kolyada <zlogene@gentoo.org>
Fri, 21 Feb 2020 18:37:56 +0000 (21:37 +0300)
Package-Manager: Portage-2.3.85, Repoman-2.3.20
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/14724
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
app-admin/terraform/Manifest
app-admin/terraform/terraform-0.12.19.ebuild [deleted file]

index e226337d75782afbda503a074a18197e3952b088..f4b4af6cdd847bbed5eaf0ffabffea91e2eaddc8 100644 (file)
@@ -1,4 +1,3 @@
 DIST terraform-0.12.17.tar.gz 10508005 BLAKE2B facef6de57333586445ce8839c03ccd633fe9ac68619e384b71fff921afeaf260e01b8783d61e4cc04882aa644e8eb706b08c88216f093d85e0fd081363c4103 SHA512 6311fdbf6764e585126a1e177dc498634a799ba1a68ba98682e2be29d14b40c09d0a780555f10bbde0587445d31a1e0d9810226f9e6bd3fcb248428ceb864c87
-DIST terraform-0.12.19.tar.gz 10526213 BLAKE2B 89acdb2e099532a922d49ac3d0049c522b7936817afb7836ebf643ef21fd35f3be495cde5a92ea93add144dada0f54de55b4b42a668bff08c9db789a1d4a77d1 SHA512 3acf327bdbaeddf6f13fc1a2a2335675dd3910137ef685224e7c1eafddf18d0aaa8c24aa3b1b5027b21905d2d87fbe3d49904e196c9881063d01670c4de3db66
 DIST terraform-0.12.20.tar.gz 10383312 BLAKE2B c9e9c7e8328cfbeb533d12a2acee133cc049b06e9a30c9fdc5708c674c272af264ae34c8c850924ae08885237a2e4d6c55d43d92b350104c6afe66d2f50e31ec SHA512 df92422426e7ebaf2c3a6b953de9fc9fcb461f7227835e728bbccf5b796995d818a39817913d6010fadb8b3618710f77f50e36eb6ce4176e7312b68c7d7f7e96
 DIST terraform-0.12.21.tar.gz 10420614 BLAKE2B 0c10cc7c33381330e7bbf20a1502019a6c651b0b0c5c3ca6713b76dd7f81a5f0d45affede0ba9ea9c2fe66585a87dc1e3be00c930d713a3eaabe865af1eb35ab SHA512 3b0dd3e6d8ae4b172d0be934ada6a8dcadc3024d0f27450ed107d55cf7f08b6b0b5eeb739a210fc9a76db42f7cc75ad5842ca7415afa3d7b17d9a34f23920a59
diff --git a/app-admin/terraform/terraform-0.12.19.ebuild b/app-admin/terraform/terraform-0.12.19.ebuild
deleted file mode 100644 (file)
index 4196f78..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit golang-base go-module
-
-DESCRIPTION="A tool for building, changing, and combining infrastructure safely"
-HOMEPAGE="https://www.terraform.io/"
-
-EGO_PN="github.com/hashicorp/${PN}"
-SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD-2 BSD-4 ECL-2.0 imagemagick ISC JSON MIT MIT-with-advertising MPL-2.0 unicode"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RESTRICT="test"
-
-DOCS=( {README,CHANGELOG}.md )
-
-src_prepare() {
-       default
-       # the sed command is necessary to generate tests outside of the
-       # default git root of `terraform', in our case the working dir
-       # is `work/$PN-$PV'
-       # sed -i -e "s/!=\s\+\"terraform\"/!=\ \"${P}\"/" \
-       #       ./scripts/generate-plugins.go || die
-}
-
-src_compile() {
-       GOCACHE="${T}/go-cache" go build \
-               -work -o "bin/${PN}" ./ || die
-}
-
-src_install() {
-       dobin bin/terraform
-
-       einstalldocs
-}
-
-pkg_postinst() {
-       elog "If you would like to install shell completions please run:"
-       elog "    terraform -install-autocomplete"
-}