Handling -fPIC for x86_64. Fixed bug #167628.
authorMarkus Nigbur <pyrania@gentoo.org>
Wed, 21 Mar 2007 10:10:23 +0000 (10:10 +0000)
committerMarkus Nigbur <pyrania@gentoo.org>
Wed, 21 Mar 2007 10:10:23 +0000 (10:10 +0000)
Package-Manager: portage-2.1.2.2

dev-libs/hashit/ChangeLog
dev-libs/hashit/hashit-0.9.4.ebuild

index 2419be3d26a93b2a15b592026fb9623d84611a2a..765d68a1b8b79092d16c888c81261d1568d0fd4d 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for dev-libs/hashit
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/hashit/ChangeLog,v 1.8 2006/11/16 11:22:03 pyrania Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/hashit/ChangeLog,v 1.9 2007/03/21 10:10:23 pyrania Exp $
+
+  21 Mar 2007; Markus Nigbur <pyrania@gentoo.org> hashit-0.9.4.ebuild:
+  Handling -fPIC for x86_64. Fixed bug #167628.
 
 *hashit-0.9.4 (16 Nov 2006)
 
index 77c028c608aa38feec978580eb4d073f0f4d107f..ff3c0e2734f5c23ce98cd6495b480f4b91672c12 100644 (file)
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/hashit/hashit-0.9.4.ebuild,v 1.1 2006/11/16 11:22:03 pyrania Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/hashit/hashit-0.9.4.ebuild,v 1.2 2007/03/21 10:10:23 pyrania Exp $
+
+inherit flag-o-matic toolchain-funcs multilib
 
 DESCRIPTION="Hashit is a library of generic hash tables that supports different collision handling methods with one common interface. Both data and keys can be of any type. It is small and easy to use."
 HOMEPAGE="http://www.pleyades.net/david/projects/"
@@ -9,19 +11,25 @@ LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~x86 ~ppc ~amd64"
 IUSE=""
-DEPEND="virtual/libc"
+DEPEND=""
 
 src_unpack() {
        unpack ${A}
-       cd ${S}
-       ./0 --prefix=${D}/usr --infodir=${D}/usr/share/info:${D}/usr/X11R6/info
+       cd "${S}"
+
+       use amd64 && append-flags -fPIC
 }
 
 src_compile() {
-       emake || die "emake failed"
+       ./0 --prefix="${D}"/usr \
+               --infodir="${D}"/usr/share/info:"${D}"/usr/X11R6/info \
+               --libdir="${D}/usr/$(get_libdir)"
+       emake GCC="$(tc-getCC)" LD="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
 }
 
 src_install() {
        einstall || die "einstall failed"
-       dosym libhashit.so /usr/lib/libhashit.so.0
+       rm "${D}/usr/$(get_libdir)/libhashit.so"
+       dosym libhashit.so.1.0 /usr/"$(get_libdir)"/libhashit.so
+       dosym libhashit.so /usr/"$(get_libdir)"/libhashit.so.0
 }