app-emulation/spice-vdagent: ebuild maintenance
authorMatthias Maier <tamiko@gentoo.org>
Sat, 14 Mar 2020 20:56:22 +0000 (15:56 -0500)
committerMatthias Maier <tamiko@gentoo.org>
Sat, 14 Mar 2020 20:56:22 +0000 (15:56 -0500)
Closes: https://bugs.gentoo.org/698408
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
app-emulation/spice-vdagent/spice-vdagent-0.19.0-r1.ebuild

index de4e147bf83334e92b2da29d92757fc0b6527d04..3610881932b8faa97bc0e727ffeeed0523064dd1 100644 (file)
@@ -1,22 +1,18 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
 inherit autotools linux-info
 
-MY_P="${P/_*/}"
-PATCHSET="${P/*_p/}"
-
 DESCRIPTION="SPICE VD Linux Guest Agent"
 HOMEPAGE="https://www.spice-space.org/"
-SRC_URI="https://www.spice-space.org/download/releases/${MY_P}.tar.bz2"
+SRC_URI="https://www.spice-space.org/download/releases/${P}.tar.bz2"
 
 LICENSE="LGPL-2.1"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="consolekit gtk selinux systemd"
-S="${WORKDIR}/${MY_P}"
 
 CDEPEND="
        >=app-emulation/spice-protocol-0.14.0
@@ -39,11 +35,6 @@ CONFIG_CHECK="~INPUT_UINPUT ~VIRTIO_CONSOLE"
 ERROR_INPUT_UINPUT="User level input support (INPUT_UINPUT) is required"
 ERROR_VIRTIO_CONSOLE="VirtIO console/serial device support (VIRTIO_CONSOLE) is required"
 
-src_prepare() {
-       default
-       eautoreconf
-}
-
 src_configure() {
        local opt=()
        if use consolekit; then