sys-libs/libomp: Remove 9.0.1 RCs and live
authorMichał Górny <mgorny@gentoo.org>
Sat, 21 Dec 2019 08:26:38 +0000 (09:26 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 21 Dec 2019 08:30:05 +0000 (09:30 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-libs/libomp/Manifest
sys-libs/libomp/libomp-9.0.1.9999.ebuild [deleted file]
sys-libs/libomp/libomp-9.0.1_rc2.ebuild [deleted file]
sys-libs/libomp/libomp-9.0.1_rc3.ebuild [deleted file]

index 8d660cd2a1d9f7a0aa819390bb1b7322ef98b150..93b3180def68cd5d27b1c926e3872628fc0094ef 100644 (file)
@@ -1,5 +1,3 @@
-DIST llvmorg-9.0.1-rc2.tar.gz 113203311 BLAKE2B 6e426060853e1587febedb75189444a1451236b713f800a4f3401c54318e48b0f5e0c484e9e4ef261faceed9b43b445a4153b061d4dadcc617047f9320b4f56a SHA512 fececd9365645920b9afdad1e94d5e10553ad4a39d84b3ac811b86014c395d51f7e4dabe54bb095a99481400c408bee3c9a2044168724d5e094e3258587a5d2c
-DIST llvmorg-9.0.1-rc3.tar.gz 113205740 BLAKE2B 3ca81e812833ecc2ac1bacfdeb86f54609ee125ba7390ce6af0113e949496149102360f35a9a0194dff93fb5cb6ade40a68382a03a7e55771a13198abb7ca9de SHA512 ea56a4ee57aacdd00a1d6551cdc768ecce3124a0eb6a9d09fe060bb147019a5119b2a9eaca576474be42e0296293daa923edd86dadb6759df0c2d7fc7a74f9f1
 DIST llvmorg-9.0.1.tar.gz 113193320 BLAKE2B b86e405f2b8e00436045fd409fe19cdde75c797b1192c62a22b5ec75e6b4dc8e874a0f33008dc31562445e4cbe53a992b6f48c684255a6a1ef261e595b8b161f SHA512 fa88beeaae94b6d0cd9b5ba38658d0ffed8004035d7d8a4f95c3d31a709b88b581ae9bd7761333c8e5375c44b8f6be01768b5a3be901163159d7e6c43b71da59
 DIST openmp-7.1.0.src.tar.xz 909320 BLAKE2B 7a5fd4374992b7c440ff27917c0af6a2ec64aaeb2fda645f75b5affd4981e3ceef7f15cba61c37934c5b35be543af315cc4bff2937545fbf5eaa6593f1aa8b83 SHA512 57f18beede401c1c39766e13a03b52083a0f7b437758069f66b73d6d1388dc51e48c34b0a7ecd3552244fd35e2db57388642588febef413c161f5c5411ab1e5d
 DIST openmp-8.0.1.src.tar.xz 933320 BLAKE2B 02a7bf70cd3a217845ef1c5a35e0d7dbfbb39069a9029d462c797b5ddf2240fd627dee55856146ca4bb81622a41f31ecd11e0ed66baf3b7d99447087271991b0 SHA512 9ded785c8129e7b3a70b54f07c4dde529456edcc94904ad77fc578cf7f096cfa3ff2279959d7f7f1db51571e11c53375f33b597c7f36ce6dc6b512c44ced8026
diff --git a/sys-libs/libomp/libomp-9.0.1.9999.ebuild b/sys-libs/libomp/libomp-9.0.1.9999.ebuild
deleted file mode 100644 (file)
index 5f49236..0000000
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-inherit cmake-multilib linux-info llvm.org multiprocessing python-any-r1
-
-DESCRIPTION="OpenMP runtime library for LLVM/clang compiler"
-HOMEPAGE="https://openmp.llvm.org"
-LLVM_COMPONENTS=( openmp )
-llvm.org_set_globals
-
-LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
-SLOT="0"
-KEYWORDS=""
-IUSE="cuda hwloc kernel_linux offload ompt test"
-# CUDA works only with the x86_64 ABI
-REQUIRED_USE="offload? ( cuda? ( abi_x86_64 ) )"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       hwloc? ( sys-apps/hwloc:0=[${MULTILIB_USEDEP}] )
-       offload? (
-               virtual/libelf:=[${MULTILIB_USEDEP}]
-               virtual/libffi:=[${MULTILIB_USEDEP}]
-               cuda? ( dev-util/nvidia-cuda-toolkit:= )
-       )"
-# tests:
-# - dev-python/lit provides the test runner
-# - sys-devel/llvm provide test utils (e.g. FileCheck)
-# - sys-devel/clang provides the compiler to run tests
-DEPEND="${RDEPEND}"
-BDEPEND="dev-lang/perl
-       offload? ( virtual/pkgconfig[${MULTILIB_USEDEP}] )
-       test? (
-               $(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]')
-               >=sys-devel/clang-6
-       )"
-
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
-python_check_deps() {
-       has_version "dev-python/lit[${PYTHON_USEDEP}]"
-}
-
-kernel_pds_check() {
-       if use kernel_linux && kernel_is -lt 4 15 && kernel_is -ge 4 13; then
-               local CONFIG_CHECK="~!SCHED_PDS"
-               local ERROR_SCHED_PDS="\
-PDS scheduler versions >= 0.98c < 0.98i (e.g. used in kernels >= 4.13-pf11
-< 4.14-pf9) do not implement sched_yield() call which may result in horrible
-performance problems with libomp. If you are using one of the specified
-kernel versions, you may want to disable the PDS scheduler."
-
-               check_extra_config
-       fi
-}
-
-pkg_pretend() {
-       kernel_pds_check
-}
-
-pkg_setup() {
-       use test && python-any-r1_pkg_setup
-}
-
-multilib_src_configure() {
-       local libdir="$(get_libdir)"
-       local mycmakeargs=(
-               -DOPENMP_LIBDIR_SUFFIX="${libdir#lib}"
-
-               -DLIBOMP_USE_HWLOC=$(usex hwloc)
-               -DLIBOMP_OMPT_SUPPORT=$(usex ompt)
-
-               -DOPENMP_ENABLE_LIBOMPTARGET=$(usex offload)
-
-               # do not install libgomp.so & libiomp5.so aliases
-               -DLIBOMP_INSTALL_ALIASES=OFF
-               # disable unnecessary hack copying stuff back to srcdir
-               -DLIBOMP_COPY_EXPORTS=OFF
-       )
-       use offload && mycmakeargs+=(
-               # this is non-fatal and libomp checks for CUDA conditionally
-               # to ABI, so we can just ignore passing the wrong value
-               # on non-amd64 ABIs
-               -DCMAKE_DISABLE_FIND_PACKAGE_CUDA=$(usex !cuda)
-       )
-       use test && mycmakeargs+=(
-               # this project does not use standard LLVM cmake macros
-               -DOPENMP_LLVM_LIT_EXECUTABLE="${EPREFIX}/usr/bin/lit"
-               -DOPENMP_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
-
-               -DOPENMP_TEST_C_COMPILER="$(type -P "${CHOST}-clang")"
-               -DOPENMP_TEST_CXX_COMPILER="$(type -P "${CHOST}-clang++")"
-       )
-       cmake-utils_src_configure
-}
-
-multilib_src_test() {
-       # respect TMPDIR!
-       local -x LIT_PRESERVES_TMP=1
-
-       cmake-utils_src_make check-libomp
-}
diff --git a/sys-libs/libomp/libomp-9.0.1_rc2.ebuild b/sys-libs/libomp/libomp-9.0.1_rc2.ebuild
deleted file mode 100644 (file)
index 50704d4..0000000
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-inherit cmake-multilib linux-info llvm.org multiprocessing python-any-r1
-
-DESCRIPTION="OpenMP runtime library for LLVM/clang compiler"
-HOMEPAGE="https://openmp.llvm.org"
-LLVM_COMPONENTS=( openmp )
-llvm.org_set_globals
-
-LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x64-macos"
-IUSE="cuda hwloc kernel_linux offload ompt test"
-# CUDA works only with the x86_64 ABI
-REQUIRED_USE="offload? ( cuda? ( abi_x86_64 ) )"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       hwloc? ( sys-apps/hwloc:0=[${MULTILIB_USEDEP}] )
-       offload? (
-               virtual/libelf:=[${MULTILIB_USEDEP}]
-               virtual/libffi:=[${MULTILIB_USEDEP}]
-               cuda? ( dev-util/nvidia-cuda-toolkit:= )
-       )"
-# tests:
-# - dev-python/lit provides the test runner
-# - sys-devel/llvm provide test utils (e.g. FileCheck)
-# - sys-devel/clang provides the compiler to run tests
-DEPEND="${RDEPEND}"
-BDEPEND="dev-lang/perl
-       offload? ( virtual/pkgconfig[${MULTILIB_USEDEP}] )
-       test? (
-               $(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]')
-               >=sys-devel/clang-6
-       )"
-
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
-python_check_deps() {
-       has_version "dev-python/lit[${PYTHON_USEDEP}]"
-}
-
-kernel_pds_check() {
-       if use kernel_linux && kernel_is -lt 4 15 && kernel_is -ge 4 13; then
-               local CONFIG_CHECK="~!SCHED_PDS"
-               local ERROR_SCHED_PDS="\
-PDS scheduler versions >= 0.98c < 0.98i (e.g. used in kernels >= 4.13-pf11
-< 4.14-pf9) do not implement sched_yield() call which may result in horrible
-performance problems with libomp. If you are using one of the specified
-kernel versions, you may want to disable the PDS scheduler."
-
-               check_extra_config
-       fi
-}
-
-pkg_pretend() {
-       kernel_pds_check
-}
-
-pkg_setup() {
-       use test && python-any-r1_pkg_setup
-}
-
-multilib_src_configure() {
-       local libdir="$(get_libdir)"
-       local mycmakeargs=(
-               -DOPENMP_LIBDIR_SUFFIX="${libdir#lib}"
-
-               -DLIBOMP_USE_HWLOC=$(usex hwloc)
-               -DLIBOMP_OMPT_SUPPORT=$(usex ompt)
-
-               -DOPENMP_ENABLE_LIBOMPTARGET=$(usex offload)
-
-               # do not install libgomp.so & libiomp5.so aliases
-               -DLIBOMP_INSTALL_ALIASES=OFF
-               # disable unnecessary hack copying stuff back to srcdir
-               -DLIBOMP_COPY_EXPORTS=OFF
-       )
-       use offload && mycmakeargs+=(
-               # this is non-fatal and libomp checks for CUDA conditionally
-               # to ABI, so we can just ignore passing the wrong value
-               # on non-amd64 ABIs
-               -DCMAKE_DISABLE_FIND_PACKAGE_CUDA=$(usex !cuda)
-       )
-       use test && mycmakeargs+=(
-               # this project does not use standard LLVM cmake macros
-               -DOPENMP_LLVM_LIT_EXECUTABLE="${EPREFIX}/usr/bin/lit"
-               -DOPENMP_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
-
-               -DOPENMP_TEST_C_COMPILER="$(type -P "${CHOST}-clang")"
-               -DOPENMP_TEST_CXX_COMPILER="$(type -P "${CHOST}-clang++")"
-       )
-       cmake-utils_src_configure
-}
-
-multilib_src_test() {
-       # respect TMPDIR!
-       local -x LIT_PRESERVES_TMP=1
-
-       cmake-utils_src_make check-libomp
-}
diff --git a/sys-libs/libomp/libomp-9.0.1_rc3.ebuild b/sys-libs/libomp/libomp-9.0.1_rc3.ebuild
deleted file mode 100644 (file)
index 50704d4..0000000
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-inherit cmake-multilib linux-info llvm.org multiprocessing python-any-r1
-
-DESCRIPTION="OpenMP runtime library for LLVM/clang compiler"
-HOMEPAGE="https://openmp.llvm.org"
-LLVM_COMPONENTS=( openmp )
-llvm.org_set_globals
-
-LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x64-macos"
-IUSE="cuda hwloc kernel_linux offload ompt test"
-# CUDA works only with the x86_64 ABI
-REQUIRED_USE="offload? ( cuda? ( abi_x86_64 ) )"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       hwloc? ( sys-apps/hwloc:0=[${MULTILIB_USEDEP}] )
-       offload? (
-               virtual/libelf:=[${MULTILIB_USEDEP}]
-               virtual/libffi:=[${MULTILIB_USEDEP}]
-               cuda? ( dev-util/nvidia-cuda-toolkit:= )
-       )"
-# tests:
-# - dev-python/lit provides the test runner
-# - sys-devel/llvm provide test utils (e.g. FileCheck)
-# - sys-devel/clang provides the compiler to run tests
-DEPEND="${RDEPEND}"
-BDEPEND="dev-lang/perl
-       offload? ( virtual/pkgconfig[${MULTILIB_USEDEP}] )
-       test? (
-               $(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]')
-               >=sys-devel/clang-6
-       )"
-
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
-python_check_deps() {
-       has_version "dev-python/lit[${PYTHON_USEDEP}]"
-}
-
-kernel_pds_check() {
-       if use kernel_linux && kernel_is -lt 4 15 && kernel_is -ge 4 13; then
-               local CONFIG_CHECK="~!SCHED_PDS"
-               local ERROR_SCHED_PDS="\
-PDS scheduler versions >= 0.98c < 0.98i (e.g. used in kernels >= 4.13-pf11
-< 4.14-pf9) do not implement sched_yield() call which may result in horrible
-performance problems with libomp. If you are using one of the specified
-kernel versions, you may want to disable the PDS scheduler."
-
-               check_extra_config
-       fi
-}
-
-pkg_pretend() {
-       kernel_pds_check
-}
-
-pkg_setup() {
-       use test && python-any-r1_pkg_setup
-}
-
-multilib_src_configure() {
-       local libdir="$(get_libdir)"
-       local mycmakeargs=(
-               -DOPENMP_LIBDIR_SUFFIX="${libdir#lib}"
-
-               -DLIBOMP_USE_HWLOC=$(usex hwloc)
-               -DLIBOMP_OMPT_SUPPORT=$(usex ompt)
-
-               -DOPENMP_ENABLE_LIBOMPTARGET=$(usex offload)
-
-               # do not install libgomp.so & libiomp5.so aliases
-               -DLIBOMP_INSTALL_ALIASES=OFF
-               # disable unnecessary hack copying stuff back to srcdir
-               -DLIBOMP_COPY_EXPORTS=OFF
-       )
-       use offload && mycmakeargs+=(
-               # this is non-fatal and libomp checks for CUDA conditionally
-               # to ABI, so we can just ignore passing the wrong value
-               # on non-amd64 ABIs
-               -DCMAKE_DISABLE_FIND_PACKAGE_CUDA=$(usex !cuda)
-       )
-       use test && mycmakeargs+=(
-               # this project does not use standard LLVM cmake macros
-               -DOPENMP_LLVM_LIT_EXECUTABLE="${EPREFIX}/usr/bin/lit"
-               -DOPENMP_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
-
-               -DOPENMP_TEST_C_COMPILER="$(type -P "${CHOST}-clang")"
-               -DOPENMP_TEST_CXX_COMPILER="$(type -P "${CHOST}-clang++")"
-       )
-       cmake-utils_src_configure
-}
-
-multilib_src_test() {
-       # respect TMPDIR!
-       local -x LIT_PRESERVES_TMP=1
-
-       cmake-utils_src_make check-libomp
-}