net-proxy/mitmproxy: bump to 4.0.4
authorTomas Mozes <hydrapolic@gmail.com>
Fri, 11 Jan 2019 07:20:35 +0000 (08:20 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Sat, 19 Jan 2019 03:21:32 +0000 (04:21 +0100)
Closes: https://bugs.gentoo.org/572170
Package-Manager: Portage-2.3.54, Repoman-2.3.12
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/10801
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
net-proxy/mitmproxy/Manifest
net-proxy/mitmproxy/mitmproxy-4.0.4.ebuild [new file with mode: 0644]

index 5e6f593164dd5b6fc43e88022d699947c5b673b5..6de72da0f04fd0bd864ad03a184b19ebf1c62e43 100644 (file)
@@ -1,3 +1,4 @@
 DIST mitmproxy-0.10.1.tar.gz 3426109 BLAKE2B 0e0822310d8b97041e6f25cb760297fb83a8544c24b0419d8215a7a65874a1c6763c6095c2e80b89231dc1de2a946471d6436713c092a1b95e7cb441f0617112 SHA512 2bef02f07942177044afa24749c4e8e2ba1aae5ee33e2cbffbecc557a09351865b70dc92b9acfd285716a82c84026a3eb93f889176fd288c1e8d67a415a5c79a
 DIST mitmproxy-0.11.1.tar.gz 6253324 BLAKE2B a3d3e06834a545138574246887c1ab5dab90d933b3995a613dabee2f6c55a436dfcb2220ded90ef91f5238d6bfcb10b2a1f64dcf801baa93598d6a8c13fadd1b SHA512 f265441825b22e2a7ec3c8f2f3152d123fbd6ac463fd4de0e973e24b2ab9feaf28689d3c995bb361ff06a88a6d88536b642944463573117640b1c096b79f20b1
 DIST mitmproxy-0.11.3.tar.gz 6172130 BLAKE2B 9001882db499e1e4a6ec082fef661a3369a36a218f3f19c08fc75d403b29b6aff22512c159a25250894e5419069ef662b691272eb5a7fbd23e2fb3e49d269adf SHA512 81184b3034b78d51368b4066adcc8337fc59332c80ce085c854610f70cd96531612520c1b751135e26093265c5475c8fef5fcb0908b77b5a18a5c605c0c94934
+DIST mitmproxy-4.0.4.tar.gz 27131713 BLAKE2B 2748b0f3b66e1f5840aae792a1b4cd8ef8efa3673fa24bc0c3e15474b36d68c0f6b2203cf629b6444545b8c6223752232b2ce8526290fe5d74916946e8917a03 SHA512 e08ea8b1c75a95b822c463625509037bbc8a979161cacaa1f0185f98df8d6d7e5400925365dbbe70d18751251b1005824f739a8cd035c0389f7b4aea562adfb3
diff --git a/net-proxy/mitmproxy/mitmproxy-4.0.4.ebuild b/net-proxy/mitmproxy/mitmproxy-4.0.4.ebuild
new file mode 100644 (file)
index 0000000..dd3a3a0
--- /dev/null
@@ -0,0 +1,83 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="An interactive, SSL-capable, man-in-the-middle HTTP proxy"
+HOMEPAGE="https://mitmproxy.org/"
+SRC_URI="https://github.com/mitmproxy/mitmproxy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+       >=dev-python/blinker-1.4[${PYTHON_USEDEP}]
+       >=dev-python/brotlipy-0.7.0[${PYTHON_USEDEP}]
+       >=dev-python/certifi-2015.11.20.1[${PYTHON_USEDEP}]
+       >=dev-python/click-6.2[${PYTHON_USEDEP}]
+       >=dev-python/cryptography-2.1.4[${PYTHON_USEDEP}]
+       >=dev-python/hyper-h2-3.0.1[${PYTHON_USEDEP}]
+       >=dev-python/hyperframe-5.1.0[${PYTHON_USEDEP}]
+       >=dev-python/kaitaistruct-0.7[${PYTHON_USEDEP}]
+       >=dev-python/ldap3-2.5[${PYTHON_USEDEP}]
+       >=dev-python/passlib-1.6.5[${PYTHON_USEDEP}]
+       >=dev-python/protobuf-python-3.6.0[${PYTHON_USEDEP}]
+       >=dev-python/pyasn1-0.3.1[${PYTHON_USEDEP}]
+       >=dev-python/pyopenssl-17.5[${PYTHON_USEDEP}]
+       >=dev-python/pyparsing-2.1.3[${PYTHON_USEDEP}]
+       >=dev-python/pyperclip-1.6.0[${PYTHON_USEDEP}]
+       >=dev-python/requests-2.9.1[${PYTHON_USEDEP}]
+       >=dev-python/ruamel-yaml-0.15[${PYTHON_USEDEP}]
+       >=dev-python/sortedcontainers-1.5.4[${PYTHON_USEDEP}]
+       >=www-servers/tornado-4.3[${PYTHON_USEDEP}]
+       >=dev-python/urwid-2.0.1[${PYTHON_USEDEP}]
+       >=dev-python/wsproto-0.11.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               >=dev-python/flask-1.0[${PYTHON_USEDEP}]
+               >=dev-python/parver-0.1[${PYTHON_USEDEP}]
+               >=dev-python/pytest-3.3[${PYTHON_USEDEP}]
+               >=dev-python/requests-2.9.1[${PYTHON_USEDEP}]
+       )"
+
+python_prepare_all() {
+       # loosen dependencies
+       sed -i '/>/s/>.*/",/g' setup.py || die
+
+       # remove failing tests
+       sed -e 's/test_iframe_injector/_&/g' \
+               -i test/examples/test_examples.py || die
+
+       sed -e 's/test_find_unclaimed_URLs/_&/g' \
+               -i test/examples/test_xss_scanner.py || die
+
+       rm test/mitmproxy/addons/test_readfile.py || die
+
+       sed \
+               -e 's/test_mode_none_should_pass_without_sni/_&/g' \
+               -e 's/test_mode_strict_w_pemfile_should_pass/_&/g' \
+               -e 's/test_mode_strict_w_confdir_should_pass/_&/g' \
+               -i test/mitmproxy/net/test_tcp.py || die
+
+       sed \
+               -e 's/test_verification_w_confdir/_&/g' \
+               -e 's/test_verification_w_pemfile/_&/g' \
+               -i test/mitmproxy/proxy/test_server.py || die
+
+       # needs pytest-asyncio
+       rm test/mitmproxy/tools/test_main.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       pytest -vv || die
+}