dev-ruby/bones: fix dependency on rake
authorHans de Graaff <graaff@gentoo.org>
Mon, 23 Jan 2017 20:07:19 +0000 (21:07 +0100)
committerHans de Graaff <graaff@gentoo.org>
Mon, 23 Jan 2017 20:08:43 +0000 (21:08 +0100)
Fix dependency on rake to match the version specified in the gemspec.
Fixes bug 606846.

Package-Manager: portage-2.3.0

dev-ruby/bones/bones-3.8.4-r1.ebuild [new file with mode: 0644]

diff --git a/dev-ruby/bones/bones-3.8.4-r1.ebuild b/dev-ruby/bones/bones-3.8.4-r1.ebuild
new file mode 100644 (file)
index 0000000..50ac277
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="default version.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Tool that creates new Ruby projects from a code skeleton"
+HOMEPAGE="https://github.com/TwP/bones"
+
+IUSE="test"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+ruby_add_rdepend "
+       dev-ruby/builder:*
+       >=dev-ruby/loquacious-1.9.1
+       >=dev-ruby/little-plugger-1.1.3
+       =dev-ruby/rake-12*"
+
+all_ruby_prepare() {
+       epatch "${FILESDIR}"/${PN}-3.8.1-builder.patch
+}