dev-python/qscintilla-python: remove 2.10.3
authorDavide Pesavento <pesa@gentoo.org>
Sat, 25 Aug 2018 18:09:12 +0000 (20:09 +0200)
committerDavide Pesavento <pesa@gentoo.org>
Sat, 25 Aug 2018 18:11:04 +0000 (20:11 +0200)
Package-Manager: Portage-2.3.48, Repoman-2.3.10

dev-python/qscintilla-python/Manifest
dev-python/qscintilla-python/qscintilla-python-2.10.3.ebuild [deleted file]

index 4f7edbb1cb0640dce96f108ad9cbaa986c4ac853..9726cb430a4c0295cd90c5272e3877a9e51b28d9 100644 (file)
@@ -1,2 +1 @@
-DIST QScintilla_gpl-2.10.3.tar.gz 2721287 BLAKE2B cc85eea17e563ae5f4a130d26ca88bec3e1a6cbff7bc0af096c63789384d03149105641d6324f53b37a2bd8ab4681a285ccb76e6063a06e5db30d070d3fd8219 SHA512 a1b9d6869797ec074e4e0727164804779792fb77b2230aae80e6d6b5fb3a3ff9d84e17d775d18ab74c97b78bac454511fd2cb49be1fa36f71d9097abf88045b6
 DIST QScintilla_gpl-2.10.4.tar.gz 2721322 BLAKE2B df50dd0a34db96dd57147ddc399d4a30751b1bb4922dc1b8b3c3c1989e810937dc8345f92128e8a606b1edc04fde4b930a424ab8344818c9899c8fe496793a77 SHA512 dee6684f68173784d098931554c839a30e129b89f980cd9704f818c44eb7023199bd3682e4b342091fa3e0ce577ec576d34046477bdd1d7fc58ca5dd2ba947a3
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.10.3.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.10.3.ebuild
deleted file mode 100644 (file)
index f683ef8..0000000
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit python-r1 qmake-utils
-
-MY_P=QScintilla_gpl-${PV/_pre/.dev}
-
-DESCRIPTION="Python bindings for Qscintilla"
-HOMEPAGE="https://www.riverbankcomputing.com/software/qscintilla/intro"
-SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 x86"
-IUSE="debug"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="
-       ${PYTHON_DEPS}
-       >=dev-python/sip-4.19:=[${PYTHON_USEDEP}]
-       dev-python/PyQt5[gui,printsupport,widgets,${PYTHON_USEDEP}]
-       dev-qt/qtcore:5
-       dev-qt/qtgui:5
-       dev-qt/qtprintsupport:5
-       dev-qt/qtwidgets:5
-       ~x11-libs/qscintilla-${PV}:=
-"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}/Python
-
-src_configure() {
-       configuration() {
-               # Fix out-of-source build and installation of .sip files
-               ln -s "${S}"/sip || die
-
-               local myconf=(
-                       "${PYTHON}"
-                       "${S}"/configure.py
-                       --pyqt=PyQt5
-                       --qmake="$(qt5_get_bindir)"/qmake
-                       --sip-incdir="$(python_get_includedir)"
-                       $(usex debug '--debug --trace' '')
-                       --verbose
-               )
-               echo "${myconf[@]}"
-               "${myconf[@]}" || die
-
-               # Run eqmake to respect toolchain, build flags, and prevent stripping
-               eqmake5 -recursive
-       }
-       python_foreach_impl run_in_build_dir configuration
-}
-
-src_compile() {
-       python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
-       installation() {
-               emake INSTALL_ROOT="${D}" install
-               python_optimize
-       }
-       python_foreach_impl run_in_build_dir installation
-}