net-p2p/retroshare: Fix build with Qt 5.11
authorAndreas Sturmlechner <asturm@gentoo.org>
Tue, 21 Aug 2018 08:23:16 +0000 (10:23 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Tue, 21 Aug 2018 08:27:16 +0000 (10:27 +0200)
Closes: https://bugs.gentoo.org/661742
Package-Manager: Portage-2.3.47, Repoman-2.3.10

net-p2p/retroshare/files/retroshare-0.6.4-qt-5.11.patch [new file with mode: 0644]
net-p2p/retroshare/retroshare-0.6.4.ebuild

diff --git a/net-p2p/retroshare/files/retroshare-0.6.4-qt-5.11.patch b/net-p2p/retroshare/files/retroshare-0.6.4-qt-5.11.patch
new file mode 100644 (file)
index 0000000..892cc89
--- /dev/null
@@ -0,0 +1,63 @@
+From 428b331d8efede1e2f39f2fc49216c675d081030 Mon Sep 17 00:00:00 2001
+From: sehraf <sehraf42@gmail.com>
+Date: Fri, 25 May 2018 23:12:35 +0200
+Subject: [PATCH] fix for Qt 5.11
+
+Quote from Arch mailing list:
+- there's been a huge header cleanup in Qt modules. Expect build failures for applications that rely on transitive includes instead of declaring all required headers. Those need to be fixed upstream by explicitely adding the missing includes.
+---
+ retroshare-gui/src/gui/Posted/PostedItem.cpp        | 1 +
+ retroshare-gui/src/gui/chat/ChatTabWidget.cpp       | 2 ++
+ retroshare-gui/src/gui/feeds/GxsChannelPostItem.cpp | 1 +
+ retroshare-gui/src/gui/feeds/GxsForumMsgItem.cpp    | 1 +
+ 4 files changed, 5 insertions(+)
+
+diff --git a/retroshare-gui/src/gui/Posted/PostedItem.cpp b/retroshare-gui/src/gui/Posted/PostedItem.cpp
+index 7d70b3e157..8fc1cc6869 100644
+--- a/retroshare-gui/src/gui/Posted/PostedItem.cpp
++++ b/retroshare-gui/src/gui/Posted/PostedItem.cpp
+@@ -22,6 +22,7 @@
+  */
+ #include <QDateTime>
++#include <QStyle>
+ #include "rshare.h"
+ #include "PostedItem.h"
+diff --git a/retroshare-gui/src/gui/chat/ChatTabWidget.cpp b/retroshare-gui/src/gui/chat/ChatTabWidget.cpp
+index a965bbb323..6dd9c27576 100644
+--- a/retroshare-gui/src/gui/chat/ChatTabWidget.cpp
++++ b/retroshare-gui/src/gui/chat/ChatTabWidget.cpp
+@@ -20,6 +20,8 @@
+  *  Boston, MA  02110-1301, USA.\r
+  ****************************************************************/\r
\r
++#include <QTabBar>\r
++\r
+ #include "ChatTabWidget.h"\r
+ #include "ui_ChatTabWidget.h"\r
+ #include "ChatDialog.h"\r
+diff --git a/retroshare-gui/src/gui/feeds/GxsChannelPostItem.cpp b/retroshare-gui/src/gui/feeds/GxsChannelPostItem.cpp
+index d154408b73..72317640c7 100644
+--- a/retroshare-gui/src/gui/feeds/GxsChannelPostItem.cpp
++++ b/retroshare-gui/src/gui/feeds/GxsChannelPostItem.cpp
+@@ -23,6 +23,7 @@
+ #include <QTimer>
+ #include <QFileInfo>
++#include <QStyle>
+ #include "rshare.h"
+ #include "GxsChannelPostItem.h"
+diff --git a/retroshare-gui/src/gui/feeds/GxsForumMsgItem.cpp b/retroshare-gui/src/gui/feeds/GxsForumMsgItem.cpp
+index 97ac9dd75a..e9773aba9c 100644
+--- a/retroshare-gui/src/gui/feeds/GxsForumMsgItem.cpp
++++ b/retroshare-gui/src/gui/feeds/GxsForumMsgItem.cpp
+@@ -23,6 +23,7 @@
+ #include <QTimer>
+ #include <QFileInfo>
++#include <QStyle>
+ #include "rshare.h"
+ #include "GxsForumMsgItem.h"
index 89ef994223cdc3fb5b02053497d45f07e597574f..1a98bba1107819f19df8eacedd2ea03d540d9d70 100644 (file)
@@ -59,7 +59,11 @@ DEPEND="${RDEPEND}
 
 S="${WORKDIR}/RetroShare-${PV}"
 
+PATCHES=( "${FILESDIR}/${P}-qt-5.11.patch" )
+
 src_prepare() {
+       default
+
        local dir
 
        sed -i \
@@ -81,8 +85,6 @@ src_prepare() {
 
        # Avoid openpgpsdk false dependency on qtgui
        sed -i '2iQT -= gui' openpgpsdk/src/openpgpsdk.pro || die
-
-       eapply_user
 }
 
 src_configure() {