dev-python/os-brick: 3.0.1 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Sat, 16 May 2020 20:56:21 +0000 (15:56 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Sat, 16 May 2020 21:21:23 +0000 (16:21 -0500)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/os-brick/Manifest
dev-python/os-brick/os-brick-3.0.1.ebuild [new file with mode: 0644]

index 028523e3ca3b1d5c1cf8d16acc09a111d3c06c59..f274dfb37d87301451a86a82c45e89ad57789405 100644 (file)
@@ -1 +1,2 @@
 DIST os-brick-2.8.2.tar.gz 179510 BLAKE2B c72c1f0260fc541a9f6ca9f984b934f718dadd7ec0909a4b2483bb190e1ad587084174a33e1a7c81a52728817286bc3887474ea2c39d7f43e8e71a4a9a4baaef SHA512 0e9237f9baf5338d123bec1b22285ff8c4c31a89d60cf8480985a144c45c2766322cb359f3d548676b2631883664c5797e687bbe4d2d9ec5cd38e10e53d394ff
+DIST os-brick-3.0.1.tar.gz 189358 BLAKE2B 331e06a49afa6d973149425946ffc3fc2b2173cc15faa9b9a6cfb231eb9e806fe10902eb86302c6a020dd4a986f0725550f12b9f54f78b9cd4fd3302d83f5eee SHA512 5283cacd1aef10a7b470d5338801fbf5741ee26ba831d12887f829f7e5744c6a9eb2db4048586214f6ed64de867645e1a6f3b5841fff5328416c5548a66dcd00
diff --git a/dev-python/os-brick/os-brick-3.0.1.ebuild b/dev-python/os-brick/os-brick-3.0.1.ebuild
new file mode 100644 (file)
index 0000000..328d913
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Cinder brick library for managing local volume attaches"
+HOMEPAGE="https://github.com/openstack/cinder"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+       !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+       !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+       >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+       !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+       !~dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
+       !~dev-python/eventlet-0.23.0[${PYTHON_USEDEP}]
+       !~dev-python/eventlet-0.25.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-log-3.26.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-i18n-3.15.3.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-privsep-1.32.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-service-1.24.0[${PYTHON_USEDEP}]
+       !~dev-python/oslo-service-1.28.1[${PYTHON_USEDEP}]
+       >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+       >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+       >=dev-python/retrying-1.2.3[${PYTHON_USEDEP}]
+       !~dev-python/retrying-1.3.0[${PYTHON_USEDEP}]
+       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+       >=dev-python/os-win-3.0.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+       sed -i '/^hacking/d' test-requirements.txt || die
+       distutils-r1_python_prepare_all
+}