Version bump for sun-jdk-1.6.0
authorVlastimil Babka <caster@gentoo.org>
Wed, 13 Dec 2006 01:26:31 +0000 (01:26 +0000)
committerVlastimil Babka <caster@gentoo.org>
Wed, 13 Dec 2006 01:26:31 +0000 (01:26 +0000)
Package-Manager: portage-2.1.2_rc3-r4

dev-java/java-sdk-docs/ChangeLog
dev-java/java-sdk-docs/files/digest-java-sdk-docs-1.6.0 [new file with mode: 0644]
dev-java/java-sdk-docs/java-sdk-docs-1.6.0.ebuild [new file with mode: 0644]

index 7d78ffa4c7bfd3813367dd37384cd5499c67a040..8899035b79aef9270f16e1de0659ac64966a3832 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-java/java-sdk-docs
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/ChangeLog,v 1.42 2006/10/14 15:51:03 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/ChangeLog,v 1.43 2006/12/13 01:26:31 caster Exp $
+
+*java-sdk-docs-1.6.0 (13 Dec 2006)
+
+  13 Dec 2006; Vlastimil Babka <caster@gentoo.org>
+  -java-sdk-docs-1.5.0.ebuild, +java-sdk-docs-1.6.0.ebuild:
+  Version bump for sun-jdk-1.6.0
 
   14 Oct 2006; Joshua Nichols <nichoj@gentoo.org>
   java-sdk-docs-1.5.0-r1.ebuild:
diff --git a/dev-java/java-sdk-docs/files/digest-java-sdk-docs-1.6.0 b/dev-java/java-sdk-docs/files/digest-java-sdk-docs-1.6.0
new file mode 100644 (file)
index 0000000..939671f
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 e1a5ecbeb576740cf673160ffae3606b jdk-6-doc.zip 54897973
+RMD160 0bb5e2294e35a06b4bb490ec6de5db7a77daee56 jdk-6-doc.zip 54897973
+SHA256 b7db4124017708e85303c0269e2e0d49639df2ff5aecbbd870e3fa35bd8ab279 jdk-6-doc.zip 54897973
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-1.6.0.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-1.6.0.ebuild
new file mode 100644 (file)
index 0000000..8f8beca
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/java-sdk-docs-1.6.0.ebuild,v 1.1 2006/12/13 01:26:31 caster Exp $
+
+SRC_URI="jdk-6-doc.zip"
+DESCRIPTION="Documentation (including API Javadocs) for Java SDK version ${PV}"
+HOMEPAGE="http://java.sun.com/javase/6/docs/"
+LICENSE="sun-j2sl-6"
+SLOT="1.6.0"
+KEYWORDS="-alpha ~amd64 -hppa -mips -ppc -sparc ~x86"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND=""
+RESTRICT="fetch"
+
+DOWNLOAD_URL="http://javashoplm.sun.com/ECom/docs/Welcome.jsp?StoreId=22&PartDetailId=jdk-6-doc-oth-JPR&SiteId=JSC&TransactionId=noreg"
+
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+       einfo "Please download ${SRC_URI} from "
+       einfo "${DOWNLOAD_URL}"
+       einfo "and place it in ${DISTDIR}"
+#      einfo "and place it in ${DISTDIR} named as"
+#      einfo "${SRC_URI}. Notice the ${PR}. Because Sun changes the doc zip file"
+#      einfo "without changing the filename, we have to resort to renaming to keep"
+#      einfo "the md5sum verification working existing and new downloads."
+#      einfo ""
+       einfo "If emerge fails because of a md5sum error it is possible that Sun"
+       einfo "has again changed the upstream release, try downloading the file"
+       einfo "again or a newer revision if available. Otherwise report this to"
+       einfo "http://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_install(){
+       insinto /usr/share/doc/${P}/html
+       doins index.html
+
+       for i in *; do
+               [[ -d $i ]] && doins -r $i
+       done
+}