dev-python/httmock: Enable py3.{7,8}
authorMichał Górny <mgorny@gentoo.org>
Thu, 23 Apr 2020 08:19:23 +0000 (10:19 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 23 Apr 2020 08:39:23 +0000 (10:39 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/httmock/httmock-1.2.5.ebuild

index 67ab6525a63d3f132c1b56d1020d2f8055a22ffc..e2eb72ff9132ce551c18a0018372adf6625dcd6f 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
 
 inherit distutils-r1
 
@@ -16,8 +16,5 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86"
 
 RDEPEND=">=dev-python/requests-1.0.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 
-python_test() {
-       esetup.py test
-}
+distutils_enable_tests setup.py