dev-util/buildbot-www: Version bump, adds python 3.7,3.8
authorBrian Dolbec <dolsen@gentoo.org>
Fri, 8 May 2020 17:40:25 +0000 (10:40 -0700)
committerBrian Dolbec <dolsen@gentoo.org>
Tue, 12 May 2020 18:15:04 +0000 (11:15 -0700)
metadata.xml: take maintainership

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
dev-util/buildbot-www/Manifest
dev-util/buildbot-www/buildbot-www-2.7.0.ebuild [new file with mode: 0644]
dev-util/buildbot-www/metadata.xml

index 15c6a35a65ef0855168045525133294696d1bd7d..05a9cff453cc782521c9104b5862633c61336981 100644 (file)
@@ -1,3 +1,4 @@
 DIST buildbot-www-0.9.12.tar.gz 691551 BLAKE2B 9bef044fe9e48e34d3e314d9c9b7446a1e295898c432da5c8915e36156f2f934fd065c8075dd55f68da7bc29a567c1ef276bc415df38911aff7c33de46fa7942 SHA512 6c525d32407be24aa728a0bd9c9a09c64bb4bef092ef9e5285475527f7fcbd89d516ea376d90b22aa24af384d73125bc886360cf992dfe3d01471838193f351a
 DIST buildbot-www-1.1.2.tar.gz 718705 BLAKE2B 009ae0dc07693f9eee4e3982ccbecb32d64e7d27e374f539cd541a5f80d9b9bf798e8836502cd26a5477b0ee842dbfae2308608fa3320e682afd0bcda2f89f1e SHA512 e4a0f7aee5e38d0522d39c819d4b9865966e020fd89b156e79807417fd7f82d497fbceafcc8a89e5beb6def1f42e4bfc595053581cbe2634520ad2c806ce3968
 DIST buildbot-www-1.3.0.tar.gz 717517 BLAKE2B 57b0ed7ef46fecb242562a0f93e234985c9cc0ea55d273c1c5de74753f6ea83d25d5017515afb6ad4b7bff4f80cdfb9a6daf937c5cd133c017c9bd6fa9d6d7ee SHA512 e01d1d3528ab1f29ff136321b25f45b01733a4f23cd9d637c9e3290b5301a8ac3dc545decb178c1332e58dc3e11065ef73df49fbb46fca6068acabdd40a8bff1
+DIST buildbot-www-2.7.0.tar.gz 3173804 BLAKE2B ac51e6b8c6860dfd98647cacd5a300099bee19b64bb796e8643fab149c96604bb63a565a25eea51dbdc458128cd4c431efbf46069f2ee0adf5f835992d860e5f SHA512 530c2e3926dbec743b9dbc3ed38ba32c421ee265dc5ff48618748a547b0e8da4d7064e6afa379a8187ec189f8031c1e24b99576d276bc5eab4ad1c6a5bc27a84
diff --git a/dev-util/buildbot-www/buildbot-www-2.7.0.ebuild b/dev-util/buildbot-www/buildbot-www-2.7.0.ebuild
new file mode 100644 (file)
index 0000000..162aae2
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+DESCRIPTION="BuildBot base web interface, use with buildbot-{console-view,waterfall-view}..."
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-www/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+       KEYWORDS=""
+else
+       KEYWORDS="~amd64"
+fi
+
+DEPEND="
+       ~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+#[[ ${PV} == *9999 ]] && S=${S}/www/base
index 0ba9d3ff6c0acad67227d36f5d73299637e47b8b..1f4ae627be1c1358b1cdd7a7b704103bb486cce3 100644 (file)
@@ -1,7 +1,10 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-       <!-- maintainer-needed -->
+       <maintainer type="person">
+               <email>dolsen@gentoo.org</email>
+               <name>Brian Dolbec</name>
+       </maintainer>
        <longdescription lang="en">
                The BuildBot-www package is the base or common code used for the other
                user interface packages such as the waterfall and console views.