net-wireless/portapack-firmware: bump
authorRick Farina <zerochaos@gentoo.org>
Wed, 8 May 2019 01:32:26 +0000 (21:32 -0400)
committerRick Farina <zerochaos@gentoo.org>
Wed, 8 May 2019 01:32:40 +0000 (21:32 -0400)
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Rick Farina <zerochaos@gentoo.org>
net-wireless/portapack-firmware/Manifest
net-wireless/portapack-firmware/portapack-firmware-20170808.ebuild [deleted file]
net-wireless/portapack-firmware/portapack-firmware-20190405.ebuild [new file with mode: 0644]

index d6e86112221a0c1624a888b1022163e13288d5d2..b59f4408c5b644ae274e23fb51a5e3ac53c2c336 100644 (file)
@@ -1 +1 @@
-DIST portapack-h1-firmware-20170808.tar.bz2 162776 BLAKE2B b21c7bd771da89ebf358ff4d68c75a1d6e7692e5592f4e0c5472e03084a98742517415c212fbc958bcb1b613a08079f80ed2658562d3b756af1a540b800294ee SHA512 f6e748dafb7412ba3cb2903554442d599a59cd25277d62516b65b1e0d513681ed886469e1eeea2065ea874b0e33289eb44fe26b9f1ea2d9e6f3e14fb791df321
+DIST portapack-h1-firmware-20190405.tar.bz2 175374 BLAKE2B 2981ee5e994e9de3f662d77fe8ebd8773f71a73980bf08474cb0d7773ce7af79a490b759bc4d0eaaec1fb1b88755bbf25968300b1c27882a07e9fe1ce9fab524 SHA512 3fe95c2fba8654233a846eac3d9dc094343aaa6e527046b8e659524aed01dc4fef4e865253fc49ac367d0fe7fe2919c20d8fed71e144290bd8ece27021aced8f
diff --git a/net-wireless/portapack-firmware/portapack-firmware-20170808.ebuild b/net-wireless/portapack-firmware/portapack-firmware-20170808.ebuild
deleted file mode 100644 (file)
index eb8c5db..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-DESCRIPTION="Firmware and scripts for controlling the Portapack from Sharebrained"
-HOMEPAGE="https://github.com/sharebrained/portapack-hackrf/releases"
-SRC_URI="https://github.com/sharebrained/portapack-hackrf/releases/download/${PV}/portapack-h1-firmware-${PV}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-PDEPEND=">=net-wireless/hackrf-tools-2015.07.2-r1
-       >=app-mobilephone/dfu-util-0.7"
-
-S="${WORKDIR}"
-
-src_install() {
-       insinto /usr/share/hackrf
-       newins portapack-h1-firmware.bin portapack-h1-firmware-${PV}.bin
-       ln -s portapack-h1-firmware-${PV}.bin "${ED}/usr/share/hackrf/portapack-h1-firmware.bin"
-
-       cat << EOF > switch_to_portapack
-#!/bin/sh
-printf "Hold down the HackRF's DFU button (the button closest to the antenna jack)\n"
-printf "then plug the HackRF into a USB port on your computer.\n"
-printf "After the HackRF is plugged in, you may release the DFU button.\n"
-printf "Press any key to continue or ^c to abort\n"
-read
-dfu-util --device 1fc9:000c --download /usr/share/hackrf/hackrf_one_usb_ram.dfu --reset
-sleep 2s
-hackrf_spiflash -w /usr/share/hackrf/portapack-h1-firmware.bin
-EOF
-       dobin switch_to_portapack
-       cat << EOF > switch_to_hackrf
-#!/bin/sh
-printf "Hold down the HackRF's DFU button (the button closest to the antenna jack)\n"
-printf "then plug the HackRF into a USB port on your computer.\n"
-printf "After the HackRF is plugged in, you may release the DFU button.\n"
-printf "Press any key to continue or ^c to abort\n"
-read
-dfu-util --device 1fc9:000c --download /usr/share/hackrf/hackrf_one_usb_ram.dfu --reset
-sleep 2s
-hackrf_spiflash -w /usr/share/hackrf/hackrf_one_usb_rom_to_ram.bin
-EOF
-       dobin switch_to_hackrf
-}
diff --git a/net-wireless/portapack-firmware/portapack-firmware-20190405.ebuild b/net-wireless/portapack-firmware/portapack-firmware-20190405.ebuild
new file mode 100644 (file)
index 0000000..5da4e1a
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Firmware and scripts for controlling the Portapack from Sharebrained"
+HOMEPAGE="https://github.com/sharebrained/portapack-hackrf/releases"
+SRC_URI="https://github.com/sharebrained/portapack-hackrf/releases/download/${PV}/portapack-h1-firmware-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+PDEPEND=">=net-wireless/hackrf-tools-2015.07.2-r1
+       >=app-mobilephone/dfu-util-0.7"
+
+S="${WORKDIR}/portapack-h1-firmware-${PV}"
+
+src_install() {
+       insinto /usr/share/hackrf
+       newins portapack-h1-firmware.bin portapack-h1-firmware-${PV}.bin
+       ln -s portapack-h1-firmware-${PV}.bin "${ED}/usr/share/hackrf/portapack-h1-firmware.bin"
+}