dev-python/mkautodoc: autodoc for mkdocs
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>
Fri, 10 Apr 2020 10:04:38 +0000 (12:04 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 16 Apr 2020 06:50:57 +0000 (09:50 +0300)
Part of effort to get mkdocs-material in ::gentoo:
https://github.com/gentoo/guru/issues/3

Package-Manager: Portage-2.3.98, Repoman-2.3.22
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Closes: https://github.com/gentoo/gentoo/pull/15286
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/mkautodoc/Manifest [new file with mode: 0644]
dev-python/mkautodoc/metadata.xml [new file with mode: 0644]
dev-python/mkautodoc/mkautodoc-0.1.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/mkautodoc/Manifest b/dev-python/mkautodoc/Manifest
new file mode 100644 (file)
index 0000000..7467e3b
--- /dev/null
@@ -0,0 +1 @@
+DIST mkautodoc-0.1.0.tar.gz 5654 BLAKE2B c0ae754e800ea25e9cccc621b4fd5c8d1561c57808b301ac5a3036ca18fda1adc432006e13b777a83dcc2cd6960a34745e17dfbcbbda24098902198d4fc9d743 SHA512 7ccb0a03016e2984d88d78eca2a8ee01e2153ff574c912358640c158b2084e3c365ace0fdb89cb74bb1950c68775d9d3cb11201cbf3c6d136dc7886a3294dc89
diff --git a/dev-python/mkautodoc/metadata.xml b/dev-python/mkautodoc/metadata.xml
new file mode 100644 (file)
index 0000000..0858ff1
--- /dev/null
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+       <maintainer type="person">
+               <email>andrewammerlaan@riseup.net</email>
+               <name>Andrew Ammerlaan</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">tomchristie/mkautodoc</remote-id>
+               <remote-id type="pypi">mkautodoc</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-python/mkautodoc/mkautodoc-0.1.0.ebuild b/dev-python/mkautodoc/mkautodoc-0.1.0.ebuild
new file mode 100644 (file)
index 0000000..bfc7f38
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Auto documentation for MkDocs"
+HOMEPAGE="
+       https://github.com/tomchristie/mkautodoc
+       https://pypi.org/project/mkautodoc
+"
+SRC_URI="https://github.com/tomchristie/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/markdown[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+       PYTHONPATH="${WORKDIR}/${P}/tests/mocklib:${WORKDIR}/${P}"
+       pytest -vv || die "tests fail with ${EPYTHON}"
+}